Jump to content
ohbothersaidpoh

Site not working - keeps hanging

Recommended Posts

Hi there

 

I haven't been able to use this site for quite a while now, but I can't handle relying on *coughcoughspeedtestcoughcough*  ​any more - my line is obviously not working properly, but *coughcoughspeedtestcoughcough* ​keeps telling me it is working at full capacity  :hmph:

 

Anyway, I digress. Whenever I try run a test (be it download, upload, or combined), it starts running, gets to about here

 
post-189071-0-04642700-1431425505_thumb.
 
and goes no further. I've tried on Chrome and Safari, before and after clearing my cache (and running cron scripts and anything else I could find that might influence it), but it keeps getting stuck. Sometimes on Chrome it gets all the way here
 
post-189071-0-64559700-1431425579.png
 
before freezing, but freeze it does.
 
 
Does anyone have any idea how to fix this? I need testmy.net back in my life  :neutral:

Share this post


Link to post
Share on other sites

Thanks for the reply, appreciate it.

 

I ran the tests as you suggested, and noticed something interesting. The upload tests work fine if I do them alone, but none of the download tests worked (consequently, running the combined test got me nowhere).

 

Just to be certain, I cleared my Chrome cache back to the beginning of time before running the tests. However, considering the results, I imagine it must be a blockage from my side. Is there anything else I can tinker with from here that might be affecting my connection? 

US East (Chrome) - "One Moment..." for 5 minutes before changing server

Asia (Chrome) - "One Moment..." for 5 minutes before changing server

Australia (Chrome) - "One Moment..." for 5 minutes before changing server

US East (Safari) - 100% downloading 256kB (see screenshot)

 

Safari stopped responding at this point, and I don't have time to fight with it now.

Share this post


Link to post
Share on other sites

Off topic a bit, but are you familiar with LittleSnitch ?

 

I've used it for years, can't work a mac without it. Hands on firewall, network monitor. 

 

My point i, you can install and use this script without paying, as their site claims. It's simply turns off after three hours. If you like it buy it. 

 

At any rate this would give you a good idea of what is happening and when, specifically. 

Share this post


Link to post
Share on other sites

Do you have another device such as a phone or tablet to try the download test?  This way it'll help rule out the ISP and router.  For example, if this problem also occurs running the download test on your phone, then you know it's not an issue with your Mac.

 

I've a friend with a Mac also and so far he has no problem running the individual tests as well as the scheduled test.  

 

Another suggestion would be to try it in a private window (Incognito mode in Chrome.)  This will rule out cookies, add-ons (unless specifically enabled for this mode) and some other non-cache related items.  

Share this post


Link to post
Share on other sites

Hi ohbothersaidpooh, sorry you're having problems.

 

Whether in disappointment, "Oh bother." or in anger, "Oh bother!" it was truly Pooh's way of politely saying "Damn it".   :laughing7:  Eeyore was always my favorite.  Watching and reading it with my daughter now and he still cracks me up.

 

Does anyone have any idea how to fix this? I need testmy.net back in my life  :neutral:

 

You're making me blush.  :P

 

Do you have wifi and a smart phone or tablet?  Any other device really... laptop, other computer.  Get connected to the same network and test.  If you're able to test (which I bet you will be) then we've established 

 

Are you running through a VPN?  These can cause issues.  TMN is capable of testing VPNs but I've seen odd behavior with certain types.  Especially web based anonymizers.  That's actually the only time on a healthy connection I've seen things like you're describing.  When those are disabled things instantly return to normal.

 

Whatever is causing it... it's a clue to an issue that is most likely affecting your speed in some way.  Sometimes when I test a device I don't even need to see the result.  I can feel by how the test loads if the device is running great.  The progress bar itself loads in different ways depending on how the data is flowing and how the device is processing.  This was not intentionally programmed to do this... it just does it.  If you use TMN enough you'll have a feeling for what it means when that bar reacts differently.  It's very hard to explain but I'm sure others experience can back me up.  Just seeing the progress bar (not even having to know how much data is being transferred) you can see fluctuations, jumpiness in the updating... in the linear download test this directly correlates with the data being loaded.  You want to see a nice smooth transition across the entire progress.  Software and hardware issues can cause the progress to jump.  Multithread's progress is always jumpy, because multiple elements can finish simultaneously.

 

Speaking of multithread.  Try a multithread speed test.  It may run when the linear test won't.  Let me know.  And let us know if you figure out what's holding you up.  It may be causing unexpected behavior on other sites and you may not even realize it yet.  :neutral:

Share this post


Link to post
Share on other sites

Whether in disappointment, "Oh bother." or in anger, "Oh bother!" it was truly Pooh's way of politely saying "Damn it".   :laughing7:  Eeyore was always my favorite.  Watching and reading it with my daughter now and he still cracks me up.

 

 It's so true. If you're looking for deep wisdoms packaged in a deceptively childlike format, look no further than the adventures of Pooh and company :)

 

So, I ran tests on my personal Macbook and Galaxy S5, and it looks like the download issue is particular to this computer (late 2012 iMac). The download test keeps getting stuck at the same place on both Chrome and Safari, while the upload test works fine.

 

*Update. Just ran the multithread test and guess what? Safari worked! Tried standard download test, and voila! It worked too. Went out on a limb and tried the combined test. SUCCESS!

 

Chrome however, is still "One Moment..."ing me. Bleugh. Chrome is my default browser, so what can I do to get Chrome purring again?

 

**UPDATE. THE MULTITHREAD DOWNLOAD TEST WORKED ON CHROME!!!! I have no idea why (because I didn't change anything), but all of a sudden, the multithread download test worked. That said, the linear test is still giving me grief. Nothing changed there :/

 

Okaaay. So, we have the culprit. The linear download test is just refusing to work on Chrome. What can I do to get it to work (short of defaulting to Safari)?

 

 

ps. Seeing your "972.9Mbps Down" makes me a little sick. My internet is slower than your by a factor of about 2000.  :tard:

Share this post


Link to post
Share on other sites

Okaaay. So, we have the culprit. The linear download test is just refusing to work on Chrome. What can I do to get it to work (short of defaulting to Safari)?

 

 

ps. Seeing your "972.9Mbps Down" makes me a little sick. My internet is slower than your by a factor of about 2000.  :tard:

As long as you don't mind clearing your settings and addons... this is what I would do at this point.

Go to Chrome settings, scroll down and click on "Advanced Settings" then scroll to the bottom and click "Reset Settings" to Restore settings to their original defaults. This is what I would do at this point.

Whatever is causing the issues if it's affecting the way the test loads it's most likely affecting the way other sites load as well. Like I said, sometimes just the fact that TMN loads at all is itself a test. It's designed to load the same on any device, any browser... something that's been tested by millions in every scenario under the Sun. So when it doesn't load... it's a strong indication something isn't right.

Let us know how it goes.

Share this post


Link to post
Share on other sites

Always fails for me in SeaMonkey.  Could be an add-on I guess, but I'm not deleting them for a speed test.

 

I have to use IE to get any results.

 

It must be add-ons or something specific to your machine.  I test as expected using SeaMonkey.  I could try on windows too but I'd bet money it works as expected.

 

:::.. Internet Speed Test Result Details ..:::
Download Connection Speed:: 128011 Kbps or 128 Mbps 
Download Speed Test Size:: 111.8 MB or 114432 kB or 117178368 bytes
Download Binary File Transfer Speed:: 16001 kB/s or 16 MB/s
Upload Connection Speed:: 19323 Kbps or 19.3 Mbps 
Upload Speed Test Size:: 8.4 MB or 8640 kB or 8847360 bytes
Upload Binary File Transfer Speed:: 2415 kB/s or 2.4 MB/s
Timed:: Download: 7.323 seconds | Upload: 3.663 seconds
Tested At:: http://TestMy.net
Test Time:: 2015-05-25 18:37:46 Local Time
Client Location:: Pike Ntl Forest, CO US http://testmy.net/city/pike_ntl_forest_c
Target:: Dallas, TX US http://testmy.net/multithread
TiP Measurement Summary (Download):: Min 60.79 Mbps | Middle Avg 129.18 Mbps | Max 133.58 Mbps | 16% Variance
TiP Data Points:: 104.21 Mbps, 133.58 Mbps, 132.94 Mbps, 131.9 Mbps, 131.48 Mbps, 132.1 Mbps, 133.15 Mbps, 129.65 Mbps, 126.91 Mbps, 128.27 Mbps, 131.07 Mbps, 130.66 Mbps, 125.02 Mbps, 127.49 Mbps, 104.21 Mbps, 132.1 Mbps, 133.15 Mbps, 132.31 Mbps, 60.79 Mbps

User Agent:: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1 [!] 

 

Fresh install, 1st attempt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
Speed Test Version 15.9
© 2017 TestMy Net LLC - TestMy.net - Terms & Privacy
© 2017 TestMy Net LLC - TestMy.net - Forum - Terms & Privacy