Jump to content

HP PSC 2355 All-in-one


compuworm
 Share

Recommended Posts

I have a HP PSC 2355 All-in-one Printer/Copier/Scanner.  I downloaded a software upgrade from HP and now I can't scan anymore.  All I get when I try is an error message indicating a communication error!  I know my printer is a Windows Image Acquisition (WIA) type, but I still can't get it to work.  I have done everything I can think of.  Any suggestions would be appreciated.

Thanks,

compuworm

Link to post
Share on other sites

Yes, I have been there numerous times and called HP support but those #$%^ing bastards want

$$$ before they will assist because my warranty ran out.  I tried to explain it was the download of their updated software which resulted in the problem but they didn't give a damn. 

I know the problem is in the communications with the scanner (Twain/WIA) but can't get it work.  I mean I have tried everything.  I know the solution is simple but can't figure it out.  Thanks to all for taking the time to reply.  I believe the answer is in the link below to some degree but still it won't work!  I tried reinstalling the old software on several different levels but  to no avail.

http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&cc=us&docname=c00273968&product=422000&dlc=en&lang=en

Link to post
Share on other sites

The error when I try to scan stays, "Communications Error when trying to communicate with scanner", I can do anything else with the printer but not scan with the full version of software.  Just to make things interesting I downloaded HP's Image Zone Express and this ALLOWS me to scan because it allows me to choose the kind of communications needed between the software and printer (WIA or TWAIN).  But this version is a real dumped down version and I want the full version damn it that is why I purchased this particular unit. 

I had opened the full version and the express version at the same time and as stated above, I can indeed scan while in the express version but when I switch to the full version can't.  Man this is really getting to me!!  This is why I am certain it has something to do the the WIA or TWAIN.  It must be somewhere in the registry settings but I can't figure it out as of yet.  I relentlessly searched the HP site for answers and there are few like the link I provided in an earlier post. 

Again, thank you all for your efforts this is indeed a great forum with great individuals.

Compuworm

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...