Jump to content
Sign in to follow this  
Sacrifist

best setting for my connection

Recommended Posts

Go to this link and download the TCP Optimizer:

https://www.speedguide.net/downloads.php

Open the TCP Optimizer and do the following:

General Settings tab:

Custom settings - check

Modify All Network Adapters - check

network adapter selection - your NIC

MTU 1500

TTL - 64

TCP Receive Window -blank

MTU Discovery - Yes

Black Hole Detect - No

Selective Acks - Yes

Max Duplicate ACKs - 2

TCP 1323 Options:

Windows Scaling - uncheck

Timestamps - uncheck

Advanced Settings tab:

Max Connections per Server - 10

Max Connections per 1.0 Server - 20

LocalPriority - 5

Host Priority - 6

DNSPriority - 7

NetbtPriority - 8

Lan Browsing speedup - optimized

QoS: NonBestEffortLimit - 0

ToS: DisableUserTOSSetting - 0

ToS: DefaultTOSValue - 240

MaxNegativeCacheTtl - 0

NetFailureCacheTime - 0

NegativeSOACache Time - 0

LAN Request Buffer Size - 32768

Then select "Apply Changes" and reboot to take effect

Then retest with https://www.speedguide.net/analyzer.php to confirm your MTU has changed.

Share this post


Link to post
Share on other sites

You can use the feature in TCP Optimizer to locate your largest MTU.

Open TCP Optimizer, set MTU to 1500, click 'Largest MTU', then enter a any website address and click 'Start'. Your comp will send out pings and establish your system's largest MTU value.

If your largest MTU value is 1450 (as limited by you ISP) then we can make a ccs file for you following this value.

Share this post


Link to post
Share on other sites

Pinging [69.25.27.171] with 40 bytes ->bytes=40 time=59ms TTL=241

Pinging [69.25.27.171] with 750 bytes ->bytes=750 time=123ms TTL=241

Pinging [69.25.27.171] with 1125 bytes ->bytes=1125 time=82ms TTL=241

Pinging [69.25.27.171] with 1312 bytes ->bytes=1312 time=109ms TTL=241

Pinging [69.25.27.171] with 1406 bytes ->bytes=1406 time=227ms TTL=241

Pinging [69.25.27.171] with 1453 bytes ->IcmpSendEcho(): 0

Pinging [67.18.179.85] with 40 bytes ->bytes=40 time=48ms TTL=50

Pinging [67.18.179.85] with 750 bytes ->bytes=750 time=233ms TTL=50

Pinging [67.18.179.85] with 1125 bytes ->bytes=1125 time=84ms TTL=50

Pinging [67.18.179.85] with 1312 bytes ->bytes=1312 time=83ms TTL=50

Pinging [67.18.179.85] with 1406 bytes ->bytes=1406 time=89ms TTL=50

Pinging [67.18.179.85] with 1453 bytes ->IcmpSendEcho(): 0

this is what it says so what is my largest MTU?

I also pinged testmy.net and came up with this

Reply from 10.10.49.1: Packet needs to be fragmented but DF set.

Packet needs to be fragmented but DF set.

Packet needs to be fragmented but DF set.

Packet needs to be fragmented but DF set.

Packets:sent = 4, Received = 1, Lost = 3 <75% loss>

Approximatel round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

Share this post


Link to post
Share on other sites

Looks like your ISP's router do not respond to the ping and so the test stop without a conclusion.

Looks like we have to go by the old-fashion way.

call out your DOS black screen and after C: use this command

ping -f -l (max value) www.testmy.net   

Where -l is minus small L  and max value is your largest anticipated MTU value minus 28.

Say you start with assumed MTU value of 1500, max value is 1500-28 = 1472

If you get a message "Packets need to be fragmented..." Then 1500 is not your largest MTU.

Go on pinging with a max value less 1 until you get a proper result like "Reply from XX.XXX.XX.XXX: bytes= ______  time = _____ ms    TTL= ___

The bytes value shown + 28 = your largest MTU.   

Share this post


Link to post
Share on other sites

1422 bytes of data:

reply from 67.18.179.85: bytes=1422 time=85ms TTL=50

reply from 67.18.179.85: bytes=1422 time=98ms TTL=50

reply from 67.18.179.85: bytes=1422 time=83ms TTL=50

reply from 67.18.179.85: bytes=1422 time=104ms TTL=50

Packets sent = 4, Received = 4, Lost = 0

Approximate round trip times in milli-seconds:

Minimum = 83ms, Maximum = 104ms, Average = 92ms

So my MTU is 1450 I take it, now what. btw, thanks for everything you have done to help me out, I appreciate it greatly

Share this post


Link to post
Share on other sites

Trogers -  what would be the best cablenut file for me?? my MTU is 1500 and my modem is capped for 8.0mbps... I am currently using Cable & DSL 30000.ccs one from vanbuners..  Here are my results from the tcp analizer

Browser/OS = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; (none); .NET CLR 1.1.4322)

Notes: Read the Analyzer FAQ if the above is not your IP address.

TCP options string = 020405b40103030301010402

MTU = 1500

MTU is fully optimized for broadband.

MSS = 1460

Maximum useful data in each packet = 1460, which equals MSS.

Default TCP Receive Window (RWIN) = 513920

RWIN Scaling (RFC1323) = 3 bits (scale factor of 6)

Unscaled TCP Receive Window = 64240

RWIN is a multiple of MSS

Other values for RWIN that might work well with your current MTU/MSS:

256960 (MSS x 44 * scale factor of 4)

128480 (MSS x 44 * scale factor of 2)

64240 (MSS x 44) 

bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 20556.8 kbps (2569.6 KBytes/s) @ 200ms

Your TCP Window limits you to: 8222.72 kbps (1027.84 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 55 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

what else would you need??  thanks for the help...

Share this post


Link to post
Share on other sites

Thanks Trogers, dled and applied already, here are my results now from the tcp analizer, and also the dl test,, please let me know if i should do anything else, as you can see is not even reaching 4 mbps although it did get better now with that file thank you...

Browser/OS = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; (none); .NET CLR 1.1.4322)

Notes: Read the Analyzer FAQ if the above is not your IP address.

TCP options string = 020405b40103030201010402

MTU = 1500

MTU is fully optimized for broadband.

MSS = 1460

Maximum useful data in each packet = 1460, which equals MSS.

Default TCP Receive Window (RWIN) = 256960

RWIN Scaling (RFC1323) = 2 bits (scale factor of 4)

Unscaled TCP Receive Window = 64240

RWIN is a multiple of MSS

Other values for RWIN that might work well with your current MTU/MSS:

513920 (MSS x 44 * scale factor of 8)

128480 (MSS x 44 * scale factor of 2)

64240 (MSS x 44) 

bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 10278.4 kbps (1284.8 KBytes/s) @ 200ms

Your TCP Window limits you to: 4111.36 kbps (513.92 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 55 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

__________________________________________

:::.. Download Stats ..:::

Connection is:: 3690 Kbps about 3.7 Mbps (tested with 2992 kB)

Download Speed is:: 450 kB/s

Tested From:: https://testmy.net (server1)

Test Time:: Sat Feb 11 12:53:38 UTC-0400 2006

Bottom Line:: 66X faster than 56K 1MB download in 2.28 sec

Diagnosis: Awesome! 20% + : 69.03 % faster than the average for host (onelinkpr.net)

Validation Link:: https://testmy.net/stats/id-PDKBQX809

Share this post


Link to post
Share on other sites

No, i am at Puerto Rico, current ISP is onelink which just took over adelphia...

here is what u asked for... and tnx again...

TCP/Web100 Network Diagnostic Tool v5.3.3d

click START to begin

Another client is currently being served, your test will begin within 45 seconds

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 461.74Kb/s

running 10s inbound test (server to client) . . . . . . 2.52Mb/s

The slowest link in the end-to-end path is a 10 Mbps Ethernet subnet

Alarm: Duplex mismatch condition exists: Host set to Full and Switch set to Half duplex

click START to re-test

WEB100 Enabled Statistics:

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 461.74Kb/s

running 10s inbound test (server to client) . . . . . . 2.52Mb/s

------  Client System Details  ------

OS data: Name = Windows XP, Architecture = x86, Version = 5.1

Java data: Vendor = Sun Microsystems Inc., Version = 1.5.0_05

------  Web100 Detailed Analysis  ------

10 Mbps Ethernet link found.

Link set to Full Duplex mode

No network congestion discovered.

Good network cable(s) found

Alarm: Duplex mismatch condition found:  Host set to Full and Switch set to Half duplexD

Web100 reports the Round trip time = 158.22 msec; the Packet size = 1460 Bytes; and

There were 31 packets retransmitted, 154 duplicate acks received, and 60 SACK blocks received

The connection was idle 0 seconds (0%) of the time

This connection is network limited 99.95% of the time.

Web100 reports TCP negotiated the optional Performance Settings to:

RFC 2018 Selective Acknowledgment: ON

RFC 896 Nagle Algorithm: ON

RFC 3168 Explicit Congestion Notification: OFF

RFC 1323 Time Stamping: OFF

RFC 1323 Window Scaling: ON

Packet size is preserved End-to-End

Server IP addresses are preserved End-to-End

Client IP addresses are preserved End-to-End

WEB100 Kernel Variables:

Client: localhost/127.0.0.1

AckPktsIn: 308

AckPktsOut: 0

BytesRetrans: 44608

CongAvoid: 23

CongestionOverCount: 0

CongestionSignals: 1

CountRTT: 146

CurCwnd: 62780

CurMSS: 1460

CurRTO: 390

CurRwinRcvd: 256960

CurRwinSent: 16304

CurSsthresh: 61320

DSACKDups: 0

DataBytesIn: 0

DataBytesOut: 3236528

DataPktsIn: 0

DataPktsOut: 2220

DupAcksIn: 154

ECNEnabled: 0

FastRetran: 1

MaxCwnd: 124100

MaxMSS: 1460

MaxRTO: 610

MaxRTT: 340

MaxRwinRcvd: 256960

MaxRwinSent: 16304

MaxSsthresh: 61320

MinMSS: 1460

MinRTO: 300

MinRTT: 100

MinRwinRcvd: 64240

MinRwinSent: 16304

NagleEnabled: 1

OtherReductions: 0

PktsIn: 308

PktsOut: 2220

PktsRetrans: 31

X_Rcvbuf: 103424

RcvWinScale: 7

SACKEnabled: 3

SACKsRcvd: 60

SendStall: 0

SlowStart: 122

SampleRTT: 110

SmoothedRTT: 140

X_Sndbuf: 103424

SndWinScale: 2

SndLimTimeRwin: 0

SndLimTimeCwnd: 10021560

SndLimTimeSender: 4968

SndLimTransRwin: 0

SndLimTransCwnd: 8

SndLimTransSender: 8

SndLimBytesRwin: 0

SndLimBytesCwnd: 2668228

SndLimBytesSender: 568300

SubsequentTimeouts: 0

SumRTT: 23100

Timeouts: 0

TimestampsEnabled: 0

WinScaleRcvd: 2

WinScaleSent: 7

DupAcksOut: 0

StartTimeUsec: 917719

Duration: 10030049

c2sData: 3

c2sAck: 3

s2cData: 8

s2cAck: 3

half_duplex: 0

link: 100

congestion: 0

bad_cable: 0

mismatch: 1

spd: 0.00

bw: 3.32

loss: 0.000450450

avgrtt: 158.22

waitsec: 0.00

timesec: 10.00

order: 0.5000

rwintime: 0.0000

sendtime: 0.0005

cwndtime: 0.9995

rwin: 1.9604

swin: 64.0000

cwin: 0.9468

rttsec: 0.158219

Sndbuf: 8388608

aspd: 7.21059

Checking for mismatch on uplink

(speed > 50 [0>50], (xmitspeed < 5) [0.46<5]

(rwintime > .9) [0>.9], (loss < .01) [4.50<.01]

Checking for excessive errors condition

(loss/sec > .15) [4.50>.15], (cwndtime > .6) [0.99>.6],

(loss < .01) [4.50<.01], (MaxSsthresh > 0) [61320>0]

Checking for 10 Mbps link

(speed < 9.5) [0<9.5], (speed > 3.0) [0>3.0]

(xmitspeed < 9.5) [0.46<9.5] (loss < .01) [4.50<.01], (mylink > 0) [10.0>0]

Checking for Wireless link

(sendtime = 0) [5.0E=0], (speed < 5) [0<5]

(Estimate > 50 [3.32>50], (Rwintime > 90) [0>.90]

(RwinTrans/CwndTrans = 1) [0/8=1], (mylink > 0) [10.0>0]

Checking for DSL/Cable Modem link

(speed < 2) [0<2], (SndLimTransSender = 0) [8=0]

(SendTime = 0) [5.0E-4=0], (mylink > 0) [10.0>0]

Checking for half-duplex condition

(rwintime > .95) [0>.95], (RwinTrans/sec > 30) [0>30],

(SenderTrans/sec > 30) [0.8>30], OR (mylink <= 10) [10.0<=10]

Checking for congestion

(cwndtime > .02) [0.99>.02], (mismatch = 0) [1=0]

(MaxSsthresh > 0) [61320>0]

estimate = 3.32 based on packet size = 11Kbits, RTT = 158.22msec, and loss = 4.5045E-4

The theoretical network limit is 3.32 Mbps

The NDT server has a 8192.0 KByte buffer which limits the throughput to 404.50 Mbps

Your PC/Workstation has a 250.0 KByte buffer which limits the throughput to 12.39 Mbps

The network based flow control limits the throughput to 5.98 Mbps

Client Data reports link is 'Ethernet', Client Acks report link is 'Ethernet'

Server Data reports link is 'OC-48', Server Acks report link is 'Ethernet'

Share this post


Link to post
Share on other sites

From this test, 2 items are limiting your speed:

"The slowest link in the end-to-end path is a 10 Mbps Ethernet subnet

Alarm: Duplex mismatch condition exists: Host set to Full and Switch set to Half duplex"

"The NDT server has a 8192.0 KByte buffer which limits the throughput to 404.50 Mbps. Your PC/Workstation has a 250.0 KByte buffer which limits the throughput to 12.39 Mbps. The network based flow control limits the throughput to 5.98 Mbps."

There is a mismatch in duplex setting between your Nic or router (if any) and your modem.

Read this link on suggestions to rectify:

http://homepage.ntlworld.com/robin.d.h.walker/cmtips/ethernet.html#ethernet

Traffic in your ISP network is only giving you a bandwidth just under 6 Mbps at the moment. Your PC has been set to a bandwidth limit of just over 12 Mbps, which is adequate for your subscribed speed. So you are limited by some heavy ISP traffic.

Share this post


Link to post
Share on other sites

trogers, thanks for looking into all that crap, cause i sure dont understad it,,, well, my eth card is already set to half duplex since is connected directly to the cable modem which is a motorola sb5100 and is what that link you gave me was basically telling to do... unless it is the modem that is set otherwise, how can i look to the modem settings??? if you need me to....

Share this post


Link to post
Share on other sites

sorry i havent posted my speeds, my isp is coming out tomorrow because my connection is having serious issues. Is there anything on my end that could be causing me not to be able to connect to any servers in Steam, or ftps. I dont have any firewalls running and according to my isp, they arent using one either. I could connect the first 2 days I had this new connection but since then I cannot get into servers. Just wondering if its something Im missing before their tech comes out tomorrow

Share this post


Link to post
Share on other sites

You seeing anything here worth discussing with the tech guy?

CP/Web100 Network Diagnostic Tool v5.3.3d

click START to begin

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 254.42Kb/s

running 10s inbound test (server to client) . . . . . . 683.81kb/s

Your PC is connected to a Cable/DSL modem

Information: Other network traffic is congesting the link

AckPktsIn: 346

AckPktsOut: 0

BytesRetrans: 7050

CongAvoid: 268

CongestionOverCount: 0

CongestionSignals: 2

CountRTT: 288

CurCwnd: 18330

CurMSS: 1410

CurRTO: 490

CurRwinRcvd: 128480

CurRwinSent: 16304

CurSsthresh: 16920

DSACKDups: 0

DataBytesIn: 0

DataBytesOut: 872790

DataPktsIn: 0

DataPktsOut: 619

DupAcksIn: 54

ECNEnabled: 0

FastRetran: 2

MaxCwnd: 33840

MaxMSS: 1410

MaxRTO: 950

MaxRTT: 560

MaxRwinRcvd: 128480

MaxRwinSent: 16304

MaxSsthresh: 16920

MinMSS: 1410

MinRTO: 360

MinRTT: 100

MinRwinRcvd: 64240

MinRwinSent: 16304

NagleEnabled: 1

OtherReductions: 0

PktsIn: 347

PktsOut: 619

PktsRetrans: 5

X_Rcvbuf: 103424

RcvWinScale: 7

SACKEnabled: 0

SACKsRcvd: 0

SendStall: 0

SlowStart: 20

SampleRTT: 120

SmoothedRTT: 190

X_Sndbuf: 103424

SndWinScale: 1

SndLimTimeRwin: 0

SndLimTimeCwnd: 10089905

SndLimTimeSender: 2686

SndLimTransRwin: 0

SndLimTransCwnd: 1

SndLimTransSender: 1

SndLimBytesRwin: 0

SndLimBytesCwnd: 872790

SndLimBytesSender: 0

SubsequentTimeouts: 0

SumRTT: 70940

Timeouts: 0

TimestampsEnabled: 0

WinScaleRcvd: 1

WinScaleSent: 7

DupAcksOut: 0

StartTimeUsec: 144415

Duration: 10093393

c2sData: 2

c2sAck: 2

s2cData: 9

s2cAck: 2

half_duplex: 0

link: 100

congestion: 1

bad_cable: 0

mismatch: 0

spd: 0.00

bw: 0.77

loss: 0.003231018

avgrtt: 246.32

waitsec: 0.00

timesec: 10.00

order: 0.1561

rwintime: 0.0000

sendtime: 0.0003

cwndtime: 0.9997

rwin: 0.9802

swin: 64.0000

cwin: 0.2582

rttsec: 0.246319

Sndbuf: 8388608

aspd: 5.11140

Checking for mismatch on uplink

(speed > 50 [0>50], (xmitspeed < 5) [0.25<5]

(rwintime > .9) [0>.9], (loss < .01) [0.00<.01]

Checking for excessive errors condition

(loss/sec > .15) [3.23>.15], (cwndtime > .6) [0.99>.6],

(loss < .01) [0.00<.01], (MaxSsthresh > 0) [16920>0]

Checking for 10 Mbps link

(speed < 9.5) [0<9.5], (speed > 3.0) [0>3.0]

(xmitspeed < 9.5) [0.25<9.5] (loss < .01) [0.00<.01], (mylink > 0) [3.0>0]

Checking for Wireless link

(sendtime = 0) [3.0E=0], (speed < 5) [0<5]

(Estimate > 50 [0.77>50], (Rwintime > 90) [0>.90]

(RwinTrans/CwndTrans = 1) [0/1=1], (mylink > 0) [3.0>0]

Checking for DSL/Cable Modem link

(speed < 2) [0<2], (SndLimTransSender = 0) [1=0]

(SendTime = 0) [3.0E-4=0], (mylink > 0) [3.0>0]

Checking for half-duplex condition

(rwintime > .95) [0>.95], (RwinTrans/sec > 30) [0>30],

(SenderTrans/sec > 30) [0.1>30], OR (mylink <= 10) [3.0<=10]

Checking for congestion

(cwndtime > .02) [0.99>.02], (mismatch = 0) [0=0]

(MaxSsthresh > 0) [16920>0]

estimate = 0.77 based on packet size = 11Kbits, RTT = 246.32msec, and loss = 0.003231018

The theoretical network limit is 0.77 Mbps

The NDT server has a 8192.0 KByte buffer which limits the throughput to 259.82 Mbps

Your PC/Workstation has a 125.0 KByte buffer which limits the throughput to 3.97 Mbps

The network based flow control limits the throughput to 1.04 Mbps

Client Data reports link is 'T1', Client Acks report link is 'T1'

Server Data reports link is '10 Gig', Server Acks report link is 'T1'

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 254.42Kb/s

running 10s inbound test (server to client) . . . . . . 683.81kb/s

------  Client System Details  ------

OS data: Name = Windows XP, Architecture = x86, Version = 5.1

Java data: Vendor = Sun Microsystems Inc., Version = 1.5.0_05

------  Web100 Detailed Analysis  ------

Cable modem/DSL/T1 link found.

Link set to Full Duplex mode

Information: throughput is limited by other network traffic.

Good network cable(s) found

Normal duplex operation found.

Web100 reports the Round trip time = 246.32 msec; the Packet size = 1410 Bytes; and

There were 5 packets retransmitted, 54 duplicate acks received, and 0 SACK blocks received

The connection was idle 0 seconds (0%) of the time

This connection is network limited 99.97% of the time.

Web100 reports TCP negotiated the optional Performance Settings to:

RFC 2018 Selective Acknowledgment: OFF

RFC 896 Nagle Algorithm: ON

RFC 3168 Explicit Congestion Notification: OFF

RFC 1323 Time Stamping: OFF

RFC 1323 Window Scaling: ON

Information: Network Middlebox is modifying MSS variable

Server IP addresses are preserved End-to-End

Share this post


Link to post
Share on other sites

"MaxMSS: 1410, MaxRwinRcvd: 128480, Round trip time = 246.32 msec"

"Your PC/Workstation has a 125.0 KByte buffer which limits the throughput to 3.97 Mbps

The network based flow control limits the throughput to 1.04 Mbps"

These are the observations from your test report:

Your RWIN is not set to a multiple of MSS

Your MSS is not optimum. It could be that your ISP has a web proxy server that change MTU values.

Carry out this ping check to find your comp's largest MTU value:

Call out your DOS black screen and after C: use this command

ping -f -l (max value) www.testmy.net 

Where -l is minus small L  and max value is your largest anticipated MTU value minus 28.

Say you start with assumed MTU value of 1500, max value is 1500-28 = 1472

If you get a message "Packets need to be fragmented..." Then 1500 is not your largest MTU.

Go on pinging with a max value less 1 until you get a proper result like "Reply from XX.XXX.XX.XXX: bytes= ______  time = _____ ms    TTL= ___

The bytes value shown + 28 = your largest MTU

At the moment, your ISP network is busy. Your comp has a buffer of 125 Kbytes giving a throughput limit of almost 4 Mbps but your network is giving you a throughput of only 1 Mbps.

Your Round Trip Time (RTT) is rather high. Usually, test performed from USA should not exceed 200 ms.

Place your modem and router a few feet apart. Make sure you have no electrical devices near them (such as sound speakers, cordless phone, etc) emitting electromagnetic interference affecting your signal flow.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...