Jump to content
Sign in to follow this  
richcornucopia

Hardrive keeps reverting to pio

Recommended Posts

Well I always thought my hardrive had started dying because it would transfer super slow, but now I have realized that it is actually in pio mode instead of dma 5 like the other drive. I've got it set to dma if available but it always goes to pio. What could the problem be?

If it's keep on reverting to PIO, it may be already damage... or you have installed a damage Harddisk.

Is it a SATA? try intalling a chipset driver !!!

Share this post


Link to post
Share on other sites

Also, they are the exact same hardrive. I cannot get it to boot when they are on the same ide channel so I have to use a different one.

I'm gonna try and explain this properly and hopefully my wording is clear enough.

Ex:

IDE cable 1) Master (Hard Drive ATA100) and a slave drive (CD Burner ATA33) .... the bios will use the lowest setting on that cable ... which would be ATA33 .... which means Your hard drive runs at ATA33

Now if You did this

IDE cable 1)Master (Hard Drive ATA100) and slave drive (your 2nd hard drive ATA100) ,then both would run at ATA100 .

I hope you understand what I mean... if not I know I can find a website on it.

So my suggestion is to find the jumper settings for your 2nd hard drive and set it to slave and hook it to the same ide cable as your main drive.

Share this post


Link to post
Share on other sites

what else can I suggest .... try unconnecting your main drive and replace it with the drive your trying to get DMA to work on and see what the bios reads. It could also be a defective cable where only one of the connectors is working right and the ohter connected might be screwed up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...