Jump to content
Sign in to follow this  
ArcticWolf

Problem with router,can't find anywhere to change MTU

Recommended Posts

Awhile back I had Bell Sympatico high speed....and I got a Speedstream 6520 modem/router combo in one from Bell.... I canceled My service with them about 3 months ago because I found a cheaper provider for the same speed download and more speed upload. But if I go to configure the router of course entering 192.168.#.# , it comes up with the Bell screen and how to set it up.... I have no problem with that.... but nowhere in the settings or advanced settings can I change the MTU from it's dang 1452 to 1492 which it should be for PPPOE. Anyone have an idea on what I can do or where to change it?

Thanks

Share this post


Link to post
Share on other sites

Ok here is something that is weird, if I look at my router settings,under the Ethernet status, it says ports 1 & 2 ,which is both of my computers is saying I'm at 100M/Full duplex and both 1500MTU ... so why is it when I go to SpeedGuide.net it says

MTU = 1452

MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.

MSS = 1412

MSS is not optimized for broadband. Consider increasing your MTU value.

Default TCP Receive Window (RWIN) = 513920

RWIN Scaling (RFC1323) = 3 bits (scale factor of 6)

Unscaled TCP Receive Window = 64240

For optimum performance, consider changing RWIN to a multiple of MSS.

Other values for RWIN that might work well with your current MTU/MSS:

519616 (MSS x 46 * scale factor of 8)

259808 (MSS x 46 * scale factor of 4)

129904 (MSS x 46 * scale factor of 2)

64952 (MSS x 46) 

bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 20556.8 kbps (2569.6 KBytes/s) @ 200ms

Your TCP Window limits you to: 8222.72 kbps (1027.84 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 53 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

Share this post


Link to post
Share on other sites

ArcticWolf ~ just off hand, would that be a Actiontec DSL  w/Wireless Networking/Gateway Modem?

The reason I ask is because that's what I have with my Qwest DSL setup. . .and it's not PPPOE, mines PPPoA and my Ethernet Link Speed I set to 10Mbps Half-Duplex and set all my  IP settings in Internet Protocol (TCP/IP)  Properties manually to get the DNS Servers to run right.

LOL ~ I'm still learning about all the DSL settings and some things still aren't making alot of sense, 'cause the way I actually set my IP address and default gateway isn't my 'REAL' (WAN) IP address nor my default gateway!! . . .but it works.

. . .like when you enter 192.168.X.X. in the address bar ~ my 'default gateway' would be Actiontec's Status/Setup modem configuration interface ~ 192.168.X.X ~ so my LAN setup is pretty generic compared to my WAN setup, which has my 'REAL' IP address and gateway.

. . .anyway, my MTU is 1500 and went with these Cablenet Adjuster settings;

for my Qwest DSL @

Download: 7168kbps

Upload: 896kbps

Latency: 100ms

MTU: 1500

DefaultReceiveWindow = 917504

DefaultSendWindow = 114688

DisableAddressSharing = 1

InitialLargeBufferCount = 200

InitialMediumBufferCount = 480

InitialSmallBufferCount = 640

LargeBufferSize = 819200

MaxFastTransmit = 64000

MediumBufferSize = 150400

Priority Boost = 1

SmallBufferSize = 12800

TransmitWorker = 32

FastSendDatagramThreshhold =

EnableFastRouteLookup = 1

EnablePMTUDiscovery = 1

IgnorePushBitsOnReceives = 0

GlobalMaxTcpWindowSize = 90520

MaxFreeTcbs =

MaxHashTableSize =

MaxNormLookupMemory =

SackOpts = 1

SynAttackProtect = 1

Tcp1323Opts = 1

TcpLogLevel = 1

TcpMaxDupAttacks = 3

TcpMaxHalfOpen = 100

TcpMaxHalfOpenRetired = 80

TcpRecvSegmentSize = 1460

TcpSendSegmentSize = 1460

TcpTimedWaitDelay = 30

TcpUseRFC1122UrgentPointer = 0

TcpWindowSize = 90520

MaxConnectionsPer1_0Server = 20

MaxConnectionsPerServer = 10

DefaultTimeToLive = 64

DefaultUserTOSSetting = 1

TcpMaxDataRetransmissions = 6

DefaultTOSValue = 240

These have been known to effect some DSL connections. If you see some minor issues, blank out these settings:

MaxNormLookupMemory

MaxFreeTcbs

MaxHashTableSize

FastSendDatagramThreshhold

[edit] . . .just changed Priority Boost = 1 and DefaultUserTOSSetting = 1

             and got a noticable increase in speed test!

[if you can, leave EnableFastRouteLookup = 1 ~ enables big increase w/speed]

:::.. Download Stats ..:::

Connection is:: 5335 Kbps about 5.3 Mbps (tested with 2992 kB)

Download Speed is:: 651 kB/s

Tested From:: https://testmy.net (server2)

Test Time:: Sun Feb 12 05:28:11 PST 2006

Bottom Line:: 95X faster than 56K 1MB download in 1.57 sec

Diagnosis: Awesome! 20% + : 140.21 % faster than the average for host (qwest.net)

Validation Link:: https://testmy.net/stats/id-XTM0WSO4R

:::.. Upload Stats ..:::

Connection is:: 762 Kbps about 0.8 Mbps (tested with 579 kB)

Upload Speed is:: 93 kB/s

Tested From:: https://testmy.net (server1)

Test Time:: Sun Feb 12 05:29:39 PST 2006

Bottom Line:: 14X faster than 56K 1MB upload in 11.01 sec

Diagnosis: Awesome! 20% + : 61.1 % faster than the average for host (qwest.net)

Validation Link:: https://testmy.net/stats/id-KYBRXEMAP

. . .not quite my 'advertised' speeds ~ but as fast as I can get it for now ~ lol

Cablenut Adjuster is always a tweak in progress ~ for me ~  :laughing7:

[edit, again] . . .now you got me all disconbobblated ~ I went to;

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParameters

and my  DefaultMSS  REG_SZ  is  1452  and  MTU  REG_DWORD  is  1492

in Interfaces my MTU is also 1492  . . .oh no, I'll try re-calculating my settings and see if it 'really' makes a difference!    . . .just when I thought I had it right ~ lol

Share this post


Link to post
Share on other sites

ArcticWolf ~ with new settings;

Download: 7168kbps

Upload: 896kbps

Latency: 100ms

MTU: 1492

DefaultReceiveWindow = 917504

DefaultSendWindow = 114688

DisableAddressSharing = 1

InitialLargeBufferCount = 200

InitialMediumBufferCount = 480

InitialSmallBufferCount = 640

LargeBufferSize = 819200

MaxFastTransmit = 64000

MediumBufferSize = 150400

Priority Boost = 1

SmallBufferSize = 12800

TransmitWorker = 32

FastSendDatagramThreshhold =

EnableFastRouteLookup = 1

EnablePMTUDiscovery = 1

IgnorePushBitsOnReceives = 0

GlobalMaxTcpWindowSize = 90024

MaxFreeTcbs =

MaxHashTableSize =

MaxNormLookupMemory =

SackOpts = 1

SynAttackProtect = 1

Tcp1323Opts = 1

TcpLogLevel = 1

TcpMaxDupAttacks = 3

TcpMaxHalfOpen = 100

TcpMaxHalfOpenRetired = 80

TcpRecvSegmentSize = 1452

TcpSendSegmentSize = 1452

TcpTimedWaitDelay = 30

TcpUseRFC1122UrgentPointer = 0

TcpWindowSize = 90024

MaxConnectionsPer1_0Server = 20

MaxConnectionsPerServer = 10

DefaultTimeToLive = 64

DefaultUserTOSSetting = 1

TcpMaxDataRetransmissions = 6

DefaultTOSValue = 240

:::.. Download Stats ..:::

Connection is:: 5336 Kbps about 5.3 Mbps (tested with 2992 kB)

Download Speed is:: 651 kB/s

Tested From:: https://testmy.net (server2)

Test Time:: Sun Feb 12 06:20:59 PST 2006

Bottom Line:: 95X faster than 56K 1MB download in 1.57 sec

Diagnosis: Awesome! 20% + : 140.14 % faster than the average for host (qwest.net)

Validation Link:: https://testmy.net/stats/id-F0R2PW5M7

:::.. Upload Stats ..:::

Connection is:: 766 Kbps about 0.8 Mbps (tested with 579 kB)

Upload Speed is:: 93 kB/s

Tested From:: https://testmy.net (server1)

Test Time:: Sun Feb 12 06:22:34 PST 2006

Bottom Line:: 14X faster than 56K 1MB upload in 11.01 sec

Diagnosis: Awesome! 20% + : 61.6 % faster than the average for host (qwest.net)

Validation Link:: https://testmy.net/stats/id-8LT3CRVPY

. . .not much difference, but when I did the TCP/IP Analyzer it still shows MTU as 1500!!

MTU = 1500

MTU is fully optimized for broadband.

MSS = 1460

Maximum useful data in each packet = 1460, which equals MSS.

Default TCP Receive Window (RWIN) = 917504

RWIN Scaling (RFC1323) = 4 bits (scale factor of 8)

Unscaled TCP Receive Window = 57344

For optimum performance, consider changing RWIN to a multiple of MSS.

Other values for RWIN that might work well with your current MTU/MSS:

513920 (MSS x 44 * scale factor of 8)

256960 (MSS x 44 * scale factor of 4)

128480 (MSS x 44 * scale factor of 2)

64240 (MSS x 44) 

bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 36700.16 kbps (4587.52 KBytes/s) @ 200ms

Your TCP Window limits you to: 14680.064 kbps (1835.008 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 54 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...