Jump to content
Sign in to follow this  
incognito

Help please

Recommended Posts

:::.. Download Stats ..:::

Connection is:: 1171 Kbps about 1.2 Mbps (tested with 748 kB)

Download Speed is:: 143 kB/s

Tested From:: https://testmy.net (server2)

Test Time:: Mon Feb 13 15:48:11 UTC+1100 2006

Bottom Line:: 21X faster than 56K 1MB download in 7.16 sec

Diagnosis: Awesome! 20% + : 31.13 % faster than the average for host (on.net)

Validation Link:: https://testmy.net/stats/id-A91P6BU7Z

i should be running close to 1500 kbps...

i know i live in australia but even so :-s what info do you need to help my settings ?

Share this post


Link to post
Share on other sites

MTU = 1460

MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.

MSS = 1420

Maximum useful data in each packet = 1420, which equals MSS.

Default TCP Receive Window (RWIN) = 63900

RWIN Scaling (RFC1323) = 0 bits

Unscaled TCP Receive Window = 63900

RWIN is a multiple of MSS

Other RWIN values that might work well with your current MTU/MSS:

522560 (MSS x 46 * scale factor of 8)

261280 (MSS x 46 * scale factor of 4)

130640 (MSS x 46 * scale factor of 2)

65320 (MSS x 46)

bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 2556 kbps (319.5 KBytes/s) @ 200ms

Your TCP Window limits you to: 1022.4 kbps (127.8 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 39 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

TCP/Web100 Network Diagnostic Tool v5.3.3d

click START to begin

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 212.61Kb/s

running 10s inbound test (server to client) . . . . . . 1.22Mb/s

Your PC is connected to a Cable/DSL modem

Information: The receive buffer should be 141.78 Kbytes to maximize throughput

Share this post


Link to post
Share on other sites

Statistics from Nitro

------ Web100 Detailed Analysis ------

Cable modem/DSL/T1 link found.

Link set to Full Duplex mode

No network congestion discovered.

Good network cable(s) found

Normal duplex operation found.

Web100 reports the Round trip time = 397.94 msec; the Packet size = 1420 Bytes; and

No packet loss - but packets arrived out-of-order 0.38% of the time

This connection is receiver limited 88.53% of the time.

Increasing the the client's receive buffer (62.0 KB) will improve performance

This connection is network limited 11.44% of the time.

Web100 reports TCP negotiated the optional Performance Settings to:

RFC 2018 Selective Acknowledgment: ON

RFC 896 Nagle Algorithm: ON

RFC 3168 Explicit Congestion Notification: OFF

RFC 1323 Time Stamping: OFF

RFC 1323 Window Scaling: OFF

More Details...

WEB100 Kernel Variables:

Client: localhost/127.0.0.1

AckPktsIn: 1034

AckPktsOut: 0

BytesRetrans: 0

CongAvoid: 0

CongestionOverCount: 0

CongestionSignals: 0

CountRTT: 1030

CurCwnd: 65320

CurMSS: 1420

CurRTO: 630

CurRwinRcvd: 63900

CurRwinSent: 16304

CurSsthresh: 2147483647

DSACKDups: 0

DataBytesIn: 0

DataBytesOut: 1529340

DataPktsIn: 0

DataPktsOut: 1077

DupAcksIn: 4

ECNEnabled: 0

FastRetran: 0

MaxCwnd: 65320

MaxMSS: 1420

MaxRTO: 790

MaxRTT: 530

MaxRwinRcvd: 63900

MaxRwinSent: 16304

MaxSsthresh: 0

MinMSS: 1420

MinRTO: 520

MinRTT: 190

MinRwinRcvd: 61060

MinRwinSent: 16304

NagleEnabled: 1

OtherReductions: 0

PktsIn: 1034

PktsOut: 1077

PktsRetrans: 0

X_Rcvbuf: 103424

RcvWinScale: 2147483647

SACKEnabled: 3

SACKsRcvd: 2

SendStall: 0

SlowStart: 44

SampleRTT: 400

SmoothedRTT: 400

X_Sndbuf: 103424

SndWinScale: 2147483647

SndLimTimeRwin: 8945729

SndLimTimeCwnd: 1156375

SndLimTimeSender: 2621

SndLimTransRwin: 1

SndLimTransCwnd: 1

SndLimTransSender: 1

SndLimBytesRwin: 1402960

SndLimBytesCwnd: 126380

SndLimBytesSender: 0

SubsequentTimeouts: 0

SumRTT: 409880

Timeouts: 0

TimestampsEnabled: 0

WinScaleRcvd: 2147483647

WinScaleSent: 2147483647

DupAcksOut: 0

StartTimeUsec: 475756

Duration: 10107423

c2sData: 2

c2sAck: 2

s2cData: 2

s2cAck: 2

half_duplex: 0

link: 100

congestion: 0

bad_cable: 0

mismatch: 0

spd: 0.00

bw: 27.22

loss: 0.000001000

avgrtt: 397.94

waitsec: 0.00

timesec: 10.00

order: 0.0039

rwintime: 0.8853

sendtime: 0.0003

cwndtime: 0.1144

rwin: 0.4875

swin: 0.7891

cwin: 0.4984

rttsec: 0.397942

Sndbuf: 103424

aspd: 6.14914

Checking for mismatch on uplink

(speed > 50 [0>50], (xmitspeed < 5) [0.21<5]

(rwintime > .9) [0.88>.9], (loss < .01) [1.0E<.01]

Checking for excessive errors condition

(loss/sec > .15) [1.0E>.15], (cwndtime > .6) [0.11>.6],

(loss < .01) [1.0E<.01], (MaxSsthresh > 0) [0>0]

Checking for 10 Mbps link

(speed < 9.5) [0<9.5], (speed > 3.0) [0>3.0]

(xmitspeed < 9.5) [0.21<9.5] (loss < .01) [1.0E<.01], (mylink > 0) [3.0>0]

Checking for Wireless link

(sendtime = 0) [3.0E=0], (speed < 5) [0<5]

(Estimate > 50 [27.22>50], (Rwintime > 90) [0.88>.90]

(RwinTrans/CwndTrans = 1) [1/1=1], (mylink > 0) [3.0>0]

Checking for DSL/Cable Modem link

(speed < 2) [0<2], (SndLimTransSender = 0) [1=0]

(SendTime = 0) [3.0E-4=0], (mylink > 0) [3.0>0]

Checking for half-duplex condition

(rwintime > .95) [0.88>.95], (RwinTrans/sec > 30) [0.1>30],

(SenderTrans/sec > 30) [0.1>30], OR (mylink <= 10) [3.0<=10]

Checking for congestion

(cwndtime > .02) [0.11>.02], (mismatch = 0) [0=0]

(MaxSsthresh > 0) [0>0]

estimate = 27.22 based on packet size = 11Kbits, RTT = 397.94msec, and loss = 1.0E-6

The theoretical network limit is 27.22 Mbps

The NDT server has a 101.0 KByte buffer which limits the throughput to 1.98 Mbps

Your PC/Workstation has a 62.0 KByte buffer which limits the throughput to 1.22 Mbps

The network based flow control limits the throughput to 1.25 Mbps

Client Data reports link is 'T1', Client Acks report link is 'T1'

Server Data reports link is 'T1', Server Acks report link is 'T1'

Share this post


Link to post
Share on other sites

We first have to try and adjust your MTU higher.

Go to this link and download the TCP Optimizer:

https://www.speedguide.net/downloads.php

Open the TCP Optimizer and do the following:

General Settings tab:

Custom settings - check

Modify All Network Adapters - check

network adapter selection - your NIC

MTU 1500

TTL - 64

TCP Receive Window - blank

MTU Discovery - Yes

Black Hole Detect - No

Selective Acks - Yes

Max Duplicate ACKs - 2

TCP 1323 Options:

Windows Scaling - uncheck

Timestamps - uncheck

Advanced Settings tab:

Max Connections per Server - 10

Max Connections per 1.0 Server - 20

LocalPriority - 5

Host Priority - 6

DNSPriority - 7

NetbtPriority - 8

Lan Browsing speedup - optimized

QoS: NonBestEffortLimit - 0

ToS: DisableUserTOSSetting - 0

ToS: DefaultTOSValue - 240

MaxNegativeCacheTtl - 0

NetFailureCacheTime - 0

NegativeSOACache Time - 0

LAN Request Buffer Size - 32768

Then select "Apply Changes" and reboot to take effect

Then retest with https://www.speedguide.net/analyzer.php to confirm your MTU value

Share this post


Link to post
Share on other sites

Max MTU

Pinging [63.217.30.70] with 40 bytes ->bytes=40 time=245ms TTL=52

Pinging [63.217.30.70] with 750 bytes ->bytes=750 time=277ms TTL=52

Pinging [63.217.30.70] with 1125 bytes ->bytes=1125 time=292ms TTL=52

Pinging [63.217.30.70] with 1312 bytes ->bytes=1312 time=298ms TTL=52

Pinging [63.217.30.70] with 1406 bytes ->bytes=1406 time=302ms TTL=52

Pinging [63.217.30.70] with 1453 bytes ->bytes=1453 time=304ms TTL=52

Pinging [63.217.30.70] with 1476 bytes -> ..fragmented

Pinging [63.217.30.70] with 1465 bytes ->IcmpSendEcho(): 0

Share this post


Link to post
Share on other sites

Looks like we have to go by the old-fashion way.

Call out  your DOS black screen and after C: use this command

ping -f -l (max value) www.testmy.net 

Where -l is minus small L  and max value is your largest anticipated MTU value minus 28.

Say you start with assumed MTU value of 1500, max value is 1500-28 = 1472

If you get a message "Packets need to be fragmented..." Then 1500 is not your largest MTU.

Go on pinging with a max value less 1 until you get a proper result like "Reply from XX.XXX.XX.XXX: bytes= ______  time = _____ ms    TTL= ___

The bytes value shown + 28 = your largest MTU. 

Share this post


Link to post
Share on other sites

Yes. This means your ISP has a web proxy server that alters your MTU values as the signals pass through it.

Here is a ccs file for MTU 1492

Download the Cablenut Adjuster from www.cablenut.com and open the ccs file.

Then Click 'Save to Registry', exit and reboot comp. Test speed again and post..

Share this post


Link to post
Share on other sites

:::.. Download Stats ..:::

Connection is:: 1254 Kbps about 1.3 Mbps (tested with 2992 kB)

Download Speed is:: 153 kB/s

Tested From:: https://testmy.net (server1)

Test Time:: Mon Feb 13 16:55:33 UTC+1100 2006

Bottom Line:: 22X faster than 56K 1MB download in 6.69 sec

Diagnosis: Awesome! 20% + : 39.96 % faster than the average for host (on.net)

Validation Link:: https://testmy.net/stats/id-B3PT6G2DV

thats downloading the largest...

but when downloading the SmarTest (in comparison to the first post i made) its the same...

:::.. Download Stats ..:::

Connection is:: 1170 Kbps about 1.2 Mbps (tested with 748 kB)

Download Speed is:: 143 kB/s

Tested From:: https://testmy.net (server2)

Test Time:: Mon Feb 13 16:56:33 UTC+1100 2006

Bottom Line:: 21X faster than 56K 1MB download in 7.16 sec

Diagnosis: Awesome! 20% + : 30.43 % faster than the average for host (on.net)

Validation Link:: https://testmy.net/stats/id-BET4V7XL5

Share this post


Link to post
Share on other sites

Your RTT value to the US is almost 400 ms. You will not be able to achieve 90% as those in the US with RTT less than 200 ms.

"estimate = 27.22 based on packet size = 11Kbits, RTT = 397.94msec, and loss = 1.0E-6

The theoretical network limit is 27.22 Mbps

The NDT server has a 101.0 KByte buffer which limits the throughput to 1.98 Mbps

Your PC/Workstation has a 62.0 KByte buffer which limits the throughput to 1.22 Mbps

The network based flow control limits the throughput to 1.25 Mbps"

This ccs file adjusts your PC's buffer from 62 Kbytes to 124 Kbytes to raise your throughput limit from 1.22 Mbps to a higher value.

You can do the nitro test again to check your throughput limit.

Share this post


Link to post
Share on other sites

estimate = 14.65 based on packet size = 11Kbits, RTT = 739.4msec, and loss = 1.0E-6

The theoretical network limit is 14.65 Mbps

The NDT server has a 8192.0 KByte buffer which limits the throughput to 86.55 Mbps

Your PC/Workstation has a 124.0 KByte buffer which limits the throughput to 1.31 Mbps

The network based flow control limits the throughput to 1.31 Mbps

Share this post


Link to post
Share on other sites

This is the best buffer value you can increase to. Any higher, you will start to have excess packet losses.

On your side, make sure you keep your router and modem a few feet apart. Electromagnetic interference from electrical devices (sound speakers, cordless phone, etc...) can increase RTT values and slow down your speed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...