Jump to content
Sign in to follow this  
cmcateer2

Comcast connection in my boat is crap :(

Recommended Posts

read through all your suggestions but here is where I think my connection & speed problems are unique.  I just had a Comcast tech out here yesterday,  I am on a boat in a marina in Florida which has been hit with many hurricanes last year and the year before Comcast has yet to come here to do any major repairs. All of their facilities run under the pier and the pier was under water for over 10 hours during Wilma last year, Now I ask what effect do you think saltwater might have on their wires and cables, the worst is that I use their broadband for my telephone service,  The Tech told me  to continue to run the speed test from this site which show uploads from 1.% of host average to 36% and sometimes usually in the dead of night 94% now what does time of day have to do with all of this?  I have changed all connections  leading from them to the boat and inside the boat.  They refuse to look at the problem beneath the piers where I am sure everything is rusting away.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...