Jump to content
Sign in to follow this  
hiteshsomai

Comdo drive not being shown in my computer

Recommended Posts

hmmm, that is really strange ~ all I can say is turn your computer off and un-plug it then plug it back and make sure the connectors are secure and tight, then turn your computer back on.

What's strange is ~ oh, wait minute ~ you said something about you can "boot CD from it"

did you mean; you can 'play' a CD in it and it works?

Share this post


Link to post
Share on other sites

Are you familiar with Registry Editor? If so, below is a quick 7 steps you can follow to have Windows XP re-detect/reinstall whatever CD drives you have on your system. The first 4 steps will backup your registry. In the event that this doesn't work for you, just run the key from My Documents, reboot, and everything will be restored to how it was prior to trying this fix. :)

1.) Run "regedit" and navigate to:

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlClass{4D36E965-E325-11CE-BFC1-08002BE10318}

When you get to the folder {4D36E965-E325-11CE-BFC1-08002BE10318}, don't expand it.

2.) Right-click on it and select "Export" (pic1).

3.) In the "Export Registry File" window, select a location (normally My Documents), give the backup file a name, and click Save (pic2).

4.) Check to see if the file is where you saved it (pic3).

5.) Now, back in Registry Editor, right-click on the same folder again and select delete.

6.) You will receive a "Confirm Key Delete" warning. Select Yes to permanently delete that key and all of its subkeys.

7.) Reboot your system.

Share this post


Link to post
Share on other sites

Ahhhh... It is done. Now i can see the drive in 'my computer'. But the problem is not completely solved. Now the case is like this:-  'solved but not completely solved'. Earlier my drive was 'secondary master' now i made it secondary slave. Now it is there in 'my computer'. If you still know the problem plz try to spare a little time.

By the way thanks to ROM-DOS and ORGAN SHIFTER.

Thank you TMN

God is great... :D

Share this post


Link to post
Share on other sites

Primary/Secondary, Master/Slave is determined by the following:

  • IDE cable position of the drive
  • IDE controller in which the drive is connected
  • Jumper position on the physical drive itself

Connecting the drive to the Primary/Secondary IDE controller isn't always enough to position the drive properly. Whether the actual drive takes on its role successfully depends on the jumper setting from the back panel (see pic) as well.

jumpersettingexample6gy.jpg

Personally, I prefer Cable Select as it allows the system to do its job and choose the correct setting for you.


Now that the jumper position is complete, lets get to the cable.

Obviously, your main Hard Drive is connected to the Primary IDE controller located on your motherboard. That move attempts to makes it the Primary Master. As long as it's connected to the Primary end of the IDE cable, it'll take on that role.

Your CD Rom drives should be connected to the Secondary IDE controller located on your motherboard. The first drive connects to Primary/ID0 while the second drive connects to Secondary/IDE1 (see pic).

idecable26kp.jpg

Double check your IDE cable/controller position along with the jumper setting (according to the example photos above). It will help you determine if your readings are correct.

Good luck. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...