Jump to content
Sign in to follow this  
bluize

Help with an external USB Drive

Recommended Posts

I have a Maxtor 250G external connected via USB. I have been using this drive for about a year as a backup storage for my backup image of my backup image (I backup my system to a 2nd hard drive and then backup the 2nd hard drive to the external USB Maxtor 250G drive, can't be too careful). Last week the Maxtor filled up completely and won't allow me access, in fact, it doesn't show up as one of my drives at all. I have tried to use Partition Magic 8.0 to lay down a partition and format the drive (system shows that the drive does not have a partition). Everytime I try to create a partition and format the drive, I get a message from Partition Magic saying that it can't create the partition and format it as drive I: (the drive letter that was used when it was added to the system the first time; even tried with diffeent drive letters, but no dice) since the system appears to have the Maxtor in use somewhere. The drive does not show up in my drive listings, however, when I look at my hardware table, it shows the Maxtor drive in the hardware table as a device on my system.

Does anyone know how I can get access to that drive and format it so it can be used (NTFS)?

Thanks in advance for any help or advice ...

Bluize

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...