Jump to content
Sign in to follow this  
Zbojnik

Registry won't open!!!

Recommended Posts

Well, I was going to try to put in some tweaks and I tried to enter my Registry. So I go to Run type in regedit and a black screen comes up, with this message coming out like a pop-up,

C:Windowssystem32regedit.com

The NTVDM CPU has encountered an illegal instruction

CS:0000 IP:20d2 OP:63 61 74 69 6e Choose Close to terminate application

Then I have to choices. Close or Ignore. If I hit ignore another comes up. It says this.

C:Windowssystem32regedit.com

Same as the other line on other error

CS:0000 IP:215b OP:ff ff ff 2f 83 Choose Close to terminate application

After that if I hit ignore it just closes.

What could be wrong? My PC is clean just did a bunch of virus scans, I haven't  toyed with my registry. What could be wrong?

Share this post


Link to post
Share on other sites

If what Peepnklown suggests doesn't work, try creating another windows user with admin rights and open regedit there.  If that doesn't work, try safe mode (and run spyware checks, and possibly registry cleaner like ccleaner).  If that doesn't work, boot to the recovery console and run the CHKDSK command.  If that don't work, format/reinstall.

Share this post


Link to post
Share on other sites

Ok, I fix one things and it leads to another. I ran that scan, then everything was fine. Then I restarted my PC and my screen went into 640x480 display with 4 bit color. And I can't change it back. What happened?

Are you in safe mode?

Share this post


Link to post
Share on other sites

Zbojnik;I don't have XP so I can only be some help.I had read some about scannow before & looked up some info on it.It has to be used correctly.

heres what I got so far:

The System File Checker in Win2k/WinXP Post Comment

The Windows File Protection is constantly checking whether important files are missing or overwritten and restores them if so. Sometimes it can happen that a file is corrupted anyway, but then one can use the util SFC.EXE with the /SCANNOW option to do a full scan of the critical files and restore those, which have become corrupted:

SFC /SCANNOW

Note this operation cannot complete without the install CD. Therefore it is important to insert the install CD before launching the above command. If the install path have changed since the original install, then one have to change the source path so SFC can find the install files.

Note if having applied a service pack, but the contents of the ServicePackFiles folder has been deleted or moved, then it will ask you for a CD with the servicepack files. To correct this one should reapply the service pack.

Note sometimes the WinXP Home will ask for the WinXP Pro CD, but this is not problem as long the above condition have been met. Though it might require that one press Retry several times before the System File Checking begins.

Note if using Win2k with SP3 or less, then the /SCANNOW will not recognize hotfixes, so they have to be reapplied after running the scan or else you will be using mixed binaries with unpredictable results.

Note SFC only works when Windows File Protection (WFP) is running. Therefore if booting in Safemode or if WFP for some reason won't start, then SFC will fail with an error similar to this:

Windows File Protection could not initiate a scan of protected system files.

I'm not sure if this would put you back where you were or not

/revert : Returns the scan to its default operation.

probably would look like this :sfc /revert

Share this post


Link to post
Share on other sites

Zbojnik.....

I had that happen to a PC I was working on a long time ago, it would not open "any" 16 bit programs.

It took forever to find out that they had a bad COMMAND.COM file in the WIDOWS/SYSTEM32 folder try replacing that file with a fresh copy from the CD or from another XP computer and see if it helps.

If all else fails you can try this program I found http://www.softpedia.com/get/Tweak/System-Tweak/16-bit-MS-DOS-Subsystem-Error-Quick-Fix.shtml

Good luck.... Let us know if that worked for you.

MYRIAGON

Share this post


Link to post
Share on other sites

I don't think it's a video problem, but you never know.

Below I attached the COMMAND.com file, just download and unzip to WINDOWS/system32 folder (if it asks to overwrite existing file click"yes"), restart PC then try accessing regedit again.

If that doesn't work, did you try downloading the program I put in my previous post ?

If not download that and run it on your system and see if that helps.

Good luck..........MYRIAGON.

Share this post


Link to post
Share on other sites

That was weird.....

When i would come to this post I showed a error on this page and din't think too much about it, what I didn't know was it was not showing all posts and I was trying to help out on a problem that was allready fixed.

Sorry everyone........

Now that I see all the posts you might try uninstalling Vid drivers and reinstalling new ones.

You may have to go to windows update also and reinstall updates.

To find system32 folder you may have to explore Tools-Folder options- View and click show hidden files, and uncheck hide protected operating system files.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...