Jump to content

External Drive Problems


Recommended Posts

Well i recently was given a kingwin 2.5" external drive enclosure. ive used it many times and it works great. but my problem is with this new 80gb drive i have in it im planning on using to back up some important data. i know the hard drive works great but when i plug it in to the enclosure and then to my computer it will either freeze up my computer when i try to open it from windows explorer. it will not allow disk management to refresh to show my drives so i can format it, and it'll lock up my computer when i try to go into properties and click "populate" to get it to read the drive and allow me to format it.

i did get it to work once so far, but when it said the drive needed to be formatted i clicked ok and it then said "windows can not format this drive"....

so now im left wondering how to get this to work.

i have windows 7 64bit home premium, and its a 80gb 2.5" laptop hard drive in an ide to usb enclosure. and the power lights and hard drive activity lights come on but still have the issues i stated above.

edit/ also, it recognizes it in windows explorer, or my computer, as drive G:

and also recognizes it in device manager and states its running fine. im about to uninstall the driver and reboot and see if that helps any. i'll post up my results.

edit#2/ still nothing. same results as before.

although its weird, when i unplug the drive it pops up saying i have to format it...so i plug it back in and click format and it doesnt do anything.

Edited by starship_troopers
Link to post
Share on other sites

I use an identical drive , 80 Gb 2.5 ex laptop drive for the same reason, in a usb enclosure , the enclosure is from pc world make unknown ,

It has 2 flying usb leads , which is inconvenient at times ,

On some computers it will work with one lead connected , but most require both usb leads to be plugged in , I think it’s something to do with current draw on the USB socket ,I think 500 Ma is the max per usb port , and can be seen in device manager ,

Can you retest the 2.5 drive in a laptop just to make sure it’s still working, ?, and maybe format it that way

I run xp , so this bit may not apply , does the computer recognize the drive when it’s plugged in , “new Device found etc” , also I have found the drive can be invisible if left plugged in on computer start up ,

Link to post
Share on other sites

thanks for your reply

and well ive used the enclosure like this before and it worked great, but yeah the enclosure has the usb cord and then a power slot that plugs into a ps2 drive, which i dont have on my laptop so i use my sleep and charge port to power and use the drive. its worked numerous times in the past and seems to work now, except that i cant access anything

and you are correct, it does say found new hardware and all that. i finally got it to recognize long enough in device manager and my computer so that i could go into command prompt and do the Format G: command and it says its working but my activity light on the enclosure only flashes a few seconds every few minutes and i have no progress being made.

and sadly no i do not have an extra laptop to plug it into. (i would take this laptop drive out and format the drive with this laptop but ive had problems with the drive not recognizing right away after ive done it before so i dont want to risk it)

Link to post
Share on other sites

well i basically gave up on it, after i plugged in everything correctly on my old dell desktop and literally sparked a fire and blew up my usb drive while it was spinning up.

im now just going to transfer all of my important data over to dvd-r discs. forget the risk of that external drive. :tickedoff:

Link to post
Share on other sites

Hell, on the fire icon_eek.gif , sorry for the delay , I am not getting notifications for some reason , I was leaning over the back of a desk top computer atempting up plug in a usb devis when a PSU capacitor went Flash/ bang big time , during the knee jerk reaction I colided with the underside of the desk , this broke the slide out keyboard mounting , I am thinking of ordering one of these for the next time icon_biggrin.gif as I already have the "T" shirt

post-22344-12730680108_thumb.jpg

post-22344-127306823243_thumb.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...