Jump to content

Very difficult network speed problem


Recommended Posts

I've got a business running on Suddenlink Cable. I'm not sure how long this has been the issue but we tried to move to VOIP a few months ago and discovered that our upload speed was insufficient for decent QOS. So I started troubleshooting.

After two different network specialists including the guy that ran the wire initially have looked at it, after replacing what was probably a good switch with a higher level Cisco 300 series managed switch, after testing a Sonic Wall and Linksys router, after replacing every patch cable in the system with a cat 6 cable (the interior cables are 5E) I still have less than .5 up and 3-4 down on a verified Suddenlink line running 8 down and 1 up.

I've plugged a computer directly into the modem on a number of occasions and the down/up signal is 8 and 1.

On a couple of occasions I've shut down the entire system and brought it back up and it will run at the correct levels for maybe an hour or so then start slowing down. The electrical in this old building was not grounded so thinking that there might be system resistance building up I put a copper stake in the ground and the box is now grounded. I still think there might be something in this but don't know what other direction to go there.

I've had an independent network installer come in and test the infrastructure lines. He had a low end fluke-like instrument and said the building wiring was good.

After that I replaced all of the patch cords. We've got maybe 30 nodes on the system. This past weekend after having changed out all the cords on Sunday with no one any system and the only activity was a couple of web cameras (Axis and Dropcam) I restarted everything but the speed was not fast even after restart.

The problem is that I can't find a specialist who knows enough to really troubleshoot the system even if I could find a fluke to plug in.

Any infrastructure gurus who might have a clue where to troubleshoot next? My business is hurting by this slowness so I'm willing to do a lot to fix it. Just don't know where to turn now.

Link to post
Share on other sites

So, you get your full speed when the modem is directly connected to the computer? Are you using the same cable from the modem to the computer as you're using from the router to the computer when you hook up directly to the modem?

I assume that this problem is seen throughout the entire network, right? It's not isolated to one machine?

I think it's your router... but that doesn't mean the router is bad. Did you used to have it connected to a DSL service? Suddenlink uses a cable modem, right? The MTU (Max Transmission Unit) setting in the router may be set incorrectly, set for your old DSL service. Look for the MTU setting in the router and change it to 1500 (this is optimal for Cable Internet). DSL is usually 1496. It may be as easy as that.

When I troubleshoot a problem like that I try to eliminate as many variables as possible. Sounds like you've done that by directly connecting the modem to one of your computers... and you found that the connection was improved. In my mind this points to the router being at fault (as long as you're troubleshooting the line with the same CAT-5 cables in both instances).

Let me know if the MTU was the issue. I've personally seen this issue first hand when switching from DSL back to Cable. I've also helped hundreds of people who've found that's their issue as well. So it wouldn't surprise me if that's the issue.

Link to post
Share on other sites

That would have been nice to have it be that simple. I just did check the MTU and it is set at 1500. I'm using dd-wrt on a Linksys router but prior to that I had a SonicWall set up and had the same problems. I even had the SW help desk look at it but, of course, they had me bypass everything and just plug one pc into the sonicwall and into the modem and the speed was fine.

As I said I've changed every cable in this place to Cat 6 hoping that the larger pipeline would eliminate the issue. But it did not work.

I think I'm going to have to find someone local who knows what they are doing (surprisingly difficult to do) and can come to the business with higher end equipment or at least a good knowledge of Wireshark or similar and have them do some real testing. I have found, after spending a day with it, that wireshark is beyond my learning in any reasonable time frame.

Link to post
Share on other sites

Been through a sonic firewall, two other routers and three switches. All with the same result. Is why I chose the very difficult network problem as a subject. I didn't expect an easy solution. Just hoping someone might have an idea. I'm going to have to find some local networking expert to run it down. Not an easy thing to find, turns out.

Link to post
Share on other sites

The times I've seen exactly what you are describing I found something hogging bandwidth. This could be anything from an incorrect loopback either terminally or via port configuration. My thought from what you say , it is internal misconfiguration.

First thing i would do is check data movement on both sides. Depending on what server your running will determine how you can test. As well as what your current switch GUI version offers.

While 1 Mb up is ok if this is s dedicated line such as a T1 , with 30 nodes ( I'm assuming you are saying you have roughly 30 workstations, that alone without configuring standard traffic ports such as 80 ,110 , 443 , ect either within the switch or on each workstation , will eat bandwidth like no tomorrow, just in normal activity. The later the operating system the more 'native' traffic.

I would start at the beginning , by numbering via static IP as well as host each workstation, and for each application running individually specify node ports by IP and or MAC ( unless you have an application server )

At least this way you can see where the traffic is coming from. If you already have the network setup this way , then you'll be looking within your local domain server (if setup) IE:AD either bind via winbin or LDAP to restrict any unwarranted data.

Would help to know what local server your running, which switch and version, as well as authentication, as above LDAP , AD ect

A note , if I had rewired the place I would have used CAT6, you have a GB switch, why not use it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...