Jump to content

DGS-1224T acting as a dummy switch - will not reset to default

Recommended Posts

I obtained this switch which works fine as a gigabit device. However resetting it via the external reset switch , appears to reset by the looks of the CPU light , as well as all current connections are reset. At the same time , the switch is still unavailable via it's default IP. 


The network is running within the same subnet as the default IP, I have also set the mac address ( obtained from the case itself ) to it's static IP within the firewall / network appliance, as well as tried others , within the same subnet. 


Using the 'smart console utility' , the switch also does not get noticed. Even typing in the default IP, it flags it as null. 


Using arp -a on the firewall appliance lists all static addresses, since there are so many, IF the mac was in the arp tables, I could not see the listing, to see if it has assigned itself an IP due to some human error on my part. 


Manually arp {mac address} returns 'unknown host'


The switch is pretty much useless without the ability to configure it. Outside of course a gigabit hub , for what I have going as i say , useless. 


Idea's of any kind are welcome !





edit: it has no serial port either, telnet is out (being  TCP utility and I have no IP ) thats out



I've also tried a tcpdump by isolating the device running a crossover cable with the following command ~

tcpdump -i en0 -s 0 -B 524288 -w ~/Desktop/DumpFile01.pcap


It would appear as if the device is not listening for any DHCP server , acting as one , or accepting any commands from anywhere. 

Link to post
Share on other sites

K, who has the goods on telnetting into a dlink switch, I have my cisco callable everything I should need / serial +/- usb support , windows : osx : linux


google is failing me on this one. 


Without being able to access the device via mac or IP, let alone getting jack squat from a TCP dump ( likely due to a VLAN previously set up on the beast ) Uhhg ! lol

Link to post
Share on other sites

This wasn't helpful for me, but I don't have one of these devices on hand...



Seems there is nothing fancy about the Reset Button or process. The device is setup to use Utility Software or a WebUI.


Have you tried ? I don't think I saw anything about it using SSL, but you may want to try that as well.

Did you pick this thing up from eBay? If you can't get it working soon you may want to contact the seller.

Link to post
Share on other sites

Yes I have seen the PDF but thanks for the link. 


I have tried that IP, even reset the entire subnet to reflect. From windows to linux and OSX machines nothing see's it or connects to it. Used a crossover cable to get a dump, each time the local card leases itself an address since the switch is acting entirely transparent. 


One though it someone wiped the firmware, at the same time would this not brick the device if done incorrectly and render it useless ?

Link to post
Share on other sites

Could be... The more I read into it the more it seems to be a brick...


Have you tried the D-Link Forums?
Different than what you have... But same general question: Is it bricked?




This guy got into a different switch using the reset... He wasn't smart enough to change his computers network to match the switch though...
It's commical, but still points more to a bricked switch for you...


Have you tried to find anything out from D-Link or other tech sites that might clue you in to what Firmware Version your switch "should" have on it. Maybe that will narrow down your search. Otherwise, D-Links forums are dogshit and so is most of what is on google...

Where did you get the device?

Link to post
Share on other sites

Yes dlink forums have always been shit, since they switched years ago, entirely worthless.


The FW and REV. is on the bottom ~ HW C1 | FW 2.00


Now what is actually there , if anything is anyones guess.


Running nmap to scan in the given local range returns all live hosts, I did a wildcard scan took all day , incidentally killed the process after dinner {and a few cocktails} , suppose I'll run this from the FW appliance shell as root ( less apt to just close a window since no window to close lol )


I suspected a bad reset switch , but the unit does 'reset' and boots. Normalk CPU activity light, and like I say , excellent as a dummy Gbit switch.


So it's not bricked per se' , possibly someone has set to only restart the switch when reset is pressed, not revert to default. Hence the nmap scan to locate the IP range it's hiding in.


I do have vlan's set up , as I've had my hands on switches which can only be accessed through a vlan. However unable to configure this within the switch itself renderts that solution useless.


The switch was obtained from a commercial sale, I do from time to time buy up office equipment in bulk, resell and discard / recycle what garb is left.

Link to post
Share on other sites

Looped the dgs 1224t through a cisco 2900-xl and used putty to watch the startup , using a serial connection ( standard cisco cable )


Assuming I might be able to see the arp cache , which i can after the IOS startup. But it shows nothing from the switch. lol


It's an old switch yes, at the same time, so what, I should still be able do something with it besides a gigabit hub. Searching drink ftp, either the firmware is hidden or they simply never released  it. Not that I could at this point even get a connection to flash it . 

Link to post
Share on other sites

Sounds like a nice dumb switch to me. Wish D-Link would have put a back-up boot loader on their device like Cisco... The only other thing I can think of is seeing if there is Flash H/W for the device on eBay that has a version on it for replacement. Sorry I'm of no* help.



Link to post
Share on other sites

My sentiments exactly. I suppose in cheap switches like this, who really needs to 'get in' /sarcasm


I could drive myself to oblivion attempting to get in sometimes. What am,azes me is the utter lack of consumer discussion out there on this line of devices. Aside this , I can take almost any store bought switch and telnet into the thing, but this pup is still evading me.


Although, I have set a static IP in pfsense, which spat out the manufacturer ID - little steps lol

Sounds like a nice dumb switch to me. Wish D-Link would have put a back-up boot loader on their device like Cisco... The only other thing I can think of is seeing if there is Flash H/W for the device on eBay that has a version on it for replacement. Sorry I'm of no* help.



Link to post
Share on other sites
  • CA3LE locked this topic
This topic is now closed to further replies.
  • Create New...