Jump to content

Windows 7 speed test oddity


Go to solution Solved by XANAVirus,

Recommended Posts

Hi,

 

I am having the weirdest problem with my Windows home PCs.

They appear to be strictly limiting themselves to 3.5 / 4Mbps download, even though my download speed is actually 15Mbps.

 

See, my server computer, which is hooked up to the same router, a Tenda Technology Wireless-N router, can fully use the download connection speed all the time, but these computers can't.

 

The speed is incredibly consistent, it *never* goes higher than 4Mbps nor does it ever go any lower than 3Mbps. But, I just can't figure out what is going on, because my other non-Windows computers and routers can use the same connection and same router to the fullest connection speed.

 

Upload speeds are fine, on all my devices I get about 1.3Mbps usually, but it's just these download speeds should be much faster than they are.

If I download a big file, like a Linux ISO, using a web browser even then it still stays at a stable 3.5 / 4 Mbps and never goes higher or drops lower.

 

Is Windows doing some sort of rate limiting itself?

 

I'm not rate limiting any on my router, and no way am I pushing either my local network or my 15Mbps cable line to anywhere near its limit.

Link to post
Share on other sites

I've seen that in OSX Snow Leopard but never got the answer why. Personally I updated to the latestest OSX and problem solved. You obviously have something else going on. If you know that the connection is faster, e.g. you have hooked another computer up the exact same way and got much better results (as you have done)... you should first look into the MTU and TCP settings. They may not be optimal. Get TCP Optimizer, set to your connection levels, reboot and retest. When I've seen issues like that in windows usually that takes care of it.

Also, look into any recently installed programs... especially along the lines of Internet security suites. In my experience those almost always screw things up, bog you down and slow down your transactions and download speed.

anyone else have input?

If you solve it, please share the solution.

Link to post
Share on other sites

Check and make sure your network adapter is not set to half duplex or 10mbps mode but auto detect or full duplex if your using wired and make sure your WiFi router isn't using wireless b also note if you connect a legacy wireless b device to your router your router will slow all WiFi connections down to that rate while it is connected

Link to post
Share on other sites

So, I ran TCP Optimizer, and that didn't change a thing. Download is still stuck at 3.5 / 4Mbps only.

The TiP line on the results page barely even deviates from a single solid line, which shows that it's really stable and therefore should be able to use more download speed.

 

I really don't think it's the router, because my WiFi devices (especially Android) can test with either Speedtest.net's app or the TMN browser based test and easily reach 7-8Mbps average (and most of the time it can download up to my max speed).

 

It only appears to be Ethernet clients that are affected by this strictly-limited speed.

 

You, TriRan, said " ... your router will slow all WiFi connections down to that rate while it is connected". Does this apply to Ethernet connections too?

 

My network is made up of 3 WiFi routers, and most devices connect at Wireless N to this router [A] which all my Ethernet clients are connected to, except for the ones that range out of router [A] and instead connect to . [C] provides coverage outside and most of the time it's empty of Wireless clients.

 

I believe the Nintendo 3DS supports Wireless G or N (in addition to Wireless B ), but even so it's actually connected to , so I don't think it is affecting anything about either WiFi or Ethernet.

 

[A] is connected to both and [C] by a 85Mbps Ethernet-over-powerline connector, because my old house doesn't have Ethernet cabling. So, I think those actually connect at only 10Mbps.

Even so, that should mean I would be able to get up 10Mbps on all my Ethernet clients, but I don't.

 

EDIT:

When I transfer files between Windows computers on router [A], I get around 10-12Mbps download/upload speed, which is pretty consistent with what I was expecting given not all my Ethernet clients connect at 100Mbps.

 

I still don't know why 3.5 /4 Mbps is the strictly enforced speed rate for only my Windows Ethernet computers, or how or where.

 

EDIT 2:

When I removed my router from the cable modem connection and plugged my computer in, when I speed tested here I got 8.4Mbps rather than the 3.5Mbps I was seeing - so it must be something to do with my router, I would suppose.

Edited by XANAVirus
Link to post
Share on other sites
  • Solution

So I managed to finally resolve this problem, just now.

 

Apparently, it turns out my router [the Tenda Technologies one] (which I had bought new to replace the one I accidentally fried) actually did have traffic controlling abilities turned on by default.

 

The setting affected the speed, in order to supposedly offer better overall latency or at least that's what the help doc says, which is how it resulted in a stable 3.5Mbps rather than my maximum connection speed like I wanted.

 

I guess it was to control congestion or something, which my network doesn't have any of as far as I know.

 

So, once I turned that off, the latency did become slightly erratic, but I gained the other 12.5Mbps I was missing in TMN speedtests.

 

This had been bugging me for like months now, but finally I solved it.

Edited by XANAVirus
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...