Jump to content

Recommended Posts

Hello Forum,


I've tried just about everything I can think of so in a last ditch effort I am going to post my problem here. Please let me know if there is another thread addressing my particular issue, if you need any more information from me, or if you have suggestions.


My Location: Orangevale, CA - USA (close to Sacramento or Folsom, CA)

My Service: Comcast Broadband Blast Pro! 200 Mbps Download, 10 Mbps Upload (D/U) speeds.

My modem: Brand new Arris Surfboard 6190 Modem with latest drivers and firmware to my knowledge, replaced my previous 5341j Zoom modem that I thought was the problem.

My router: Brand new Linksys WRT1900ACS with latest drivers and firmware, replaced my previous ASUS RTN66R router which I thought was the problem.

Ethernet Cable A & B

I own my router and modem.


My issue: When I am plugged directly into my modem (either one) with Ethernet Cable A or B and I test my internet speed on all of the other speedtests and testmy I get my advertised speeds or close to it. When I introduce the router (either one) and use a wired connection with either ethernet cable A or B plugged into any port on the router or use Wi-fi, my speed drops to around 30/10 D/U or 20/10 D/U on wireless, sometimes even worse, tested at all times of the day, with only one device connected. Having tried everything I will list below I can only conclude that there is something wrong with how my ISP, Modem, and Router interact with the devices in my house but I can't figure it out. My modem and router sit fairly close to each other, on a desk in a single story 1250 sq ft house made of drywall and studs with a stucco interior, so incredibly ordinary.


Here is what I've tried:

1. Comcast replaced the connection heads on my coaxial cable

2. Comcast reprovisioned the modem and resent the signal

3. I replaced all of the hardware. I feel my testing as eliminated the modem, the cables, and the laptop as the problem, as the issue only happens with the introduction of the router. So I can assume either the router, the router's settings, or the interface between all of the devices is the problem. I conclude this based on the issue being persistent over wired and wireless connections and persisting over two different routers.

4. Messed with router settings. QoS off, DHCP enabled, 5 ghz off, 2.4 ghz is wpa2 personal with a hidden SSID, WMM is off. I'm not sure if other settings will help.

5. Searched forums for linksys and asus, couldn't find much, I tried flashing the Asus to tomato shibby but the problem got worse so I flashed it back and now it sits unused

6. Looked at jitter, latency, and ping. The numbers were decent I'd say, nothing unreasonable. The jitter might have been a little high coming off the direct modem connection, but it wasn't in the red zone.

7. Tried factory resets a couple of times, and power cycles

8. updated drivers on my laptop for my NIC cards


I'm sure I've tried more, but that is all I can think of now. I am really at a loss for how to fix this problem. All of the other unreliable speed tests have me at advertised speeds through the router, except for a decent and expected slow down on wifi, but I trust testmy and I notice that my speed and connectivity are rarely as good as they should be. In fact every day I usually have to do "troubleshoot my internet connection" on my laptop to get the connection to reconnect. My laptop is an ASUS (forgot the model number right now) with Windows 7.


Thank you for taking the time to read this and let me know if you have questions.

















Link to post
Share on other sites

The cabling between the modem and router would be the first thing to test further. Although cat5/e can handle that throughput,

I would consider using a cat6a cable between the modem and the router. Even 24gauge. Also attempting to rule out pinout issues by getting a higher end network cable. (In the case of the same manufacturer / lot# of the two existing wires), though I assume your using the same wire when testing modem to laptop.


Just an fyi, I've come across quite a few machines as of late running windows 7, where there is some network issue, either not allowing the end user to connect to a wifi point, or outlook claiming no connection where mails can still be sent and received. So I do not rule out some bad update.


Have you tested a second machine or device on the network, not running windows 7? Results?


Link to post
Share on other sites

Hi Mudmanc4,


Thank you for the reply. To answer your questions:


1. I have two cables A and B, I've tried both of them in modem to laptop and reversed them in the modem to router to laptop configurations. I get advertised speeds with both cables when doing modem to laptop, and 30 D 10 U when I introduce the router. Also my wireless speed is usually around 20 D 5-10 U so even it is 10% the download speed it should be. However, I should probably invest in some Cat 6 anyways so I will get some and report back.


2. I've tested on my Galaxy S5 on wireless with the same slow results (through Chrome) and my PS4 also has slow results (it's running on ethernet over power the TPlink devices). I only have one other laptop, that is a Windows 8, which I will try tonight and get back to you. It's my wife's laptop so I try not to touch it, but I should have thought to troubleshoot on that one as well to completely eliminate the Laptop.


My main concern is that the slowdown seems to occur only when I introduce a router, and while I expect some loss in bandwidth I don't expect to see a drop from 150-200 to 20-30.



- Michael

Link to post
Share on other sites





Tested it on my wife's Windows 8.1 computer, same results in terms of speed.


As for the modem log I get the No Ranging Response received - T3 or T4 time-out maybe once every 3-4 days, I cleared the log and ran the test a couple of more times, nothing as of yet, but I will let you know.


I ordered the Cat 6a cables to see if that will be a change.


I'm going to try booting up in safe mode w/ networking and see if maybe some application isn't playing nice with my router. I just thought of it, that maybe AVG or windows firewall could be fine with my modem but then give me a problem with the router, we'll see.



- Mike

Link to post
Share on other sites

Concerning the no range response, what were the power levels, if you noticed while in there. Or just have another peek.

Though that error is rather common.

You might be on to something with testing from a known clean machine, including no addons, antivirus and software firewalls active on the local machine.


Link to post
Share on other sites

Hi Mudmanc4,




I had a comcast tech come out, and I don't know how much of what he said was right/wrong but his basic message was: "I should rent a modem/router combo from them because the owned ones don't get updated right so you have to buy a new one at $200 a pop every 2 years anyways so you're not saving money, but if you don't want to do that buy the Netgear AC1900 router/broadband modem combo "nighthawk", also Comcast and Linksys don't get along and we have problems with the Arris modems too".



Since the Nighthawk was cheaper in total than the modem + router I recently bought, and I didn't want to argue about the fact I had a Zoom modem and Asus router before with the same problem, I decided to return the arris and linksys and get the nighthawk instead.


I plugged it in and have it all fired up. Over wired connection this was my speed:





Wireless 2.4 Ghz Laptop 1:



Wireless 5 Ghz Galaxy S5:

122.9 Mbps and 7.8 Mbps


The second laptop gets similar results as my first laptop on 2.4 ghz and similar results as my phone on 5 ghz. This leads me to believe that the 2.4 Ghz band is the problem (which I don't doubt given I live in a suburb with at least 15 other wifi signals available to me and probably a bunch more 2.4 ghz noise interference) with that and that there must have been some connectivity issue between my router and modem that is now resolved with it being a combo unit. I can only assume that you were right and that the cat 5e cable was the issue, but stupid me I ordered those cables without prime shipping but ordered the combo unit with prime so the cables aren't here yet for me to test.


Thanks again for all of your help and I really love this site to get accurate information about my issues. For now I think I am going to count my blessings that I can get close enough to my advertised speeds on everything but 2.4 ghz and worry about that at another time, since I suspect I can't fix it.


- Michael




Link to post
Share on other sites
  • CA3LE locked this topic
This topic is now closed to further replies.
  • Create New...