Jump to content

Terrible FIOS data rates ...


Recommended Posts

So I have had FIOS for about 9 years now, and have generally been very happy.  My current plan is 75 Mbps up and down, but in the last few weeks I have had horrific performance. Last night downloading a new game from STEAM I was getting a bit more than 1 Mbps.  My results here have been in the single digits, generally less than 5.


This site claims the average FIOS link to here is in the 50Mbps range.  How current is that?  I am near Baltimore, so when I run the FIOS speed test it connects to a server near DC, and my connection to VERIZON averages around 90Mbps up and down. 


So obviously the problem is somewhere between verizon and the rest of the network, but when I call and complain of course the response is "it isn't our problem", yet I have no way to test that.  Any other FIOS users in the DC/Baltimore area with current tests?





Link to comment
Share on other sites

Welcome not_a_happy_camper!


First, the averages are always current.  They are just brought down by people with slower results.


By default it shows the last 50 download and 50 upload test results.


Screen Shot 2017-01-21 at 5.04.53 AM.png


change the drop down


Screen Shot 2017-01-21 at 5.05.02 AM.png


Screen Shot 2017-01-21 at 5.05.11 AM.png


Looking at Verizon FIOS speed test log

Screen Shot 2017-01-21 at 5.24.29 AM.png


I find some people with faster results but when I look closer at the 'connectID' results, some display a seesaw pattern.




But then I find a result for someone in Belcamp, MD and they're consistent.  Although they haven't tested as often.



Here's one in NJ that's incredibly stable



Are you using wifi?  Have you tried testing directly connected (ethernet) to the modem or router?


A 50 Mbps is a high overall average for an ISP on TestMy.net.  Look at the top Internet performers.


Screen Shot 2017-01-21 at 7.08.04 AM.png

Link to comment
Share on other sites



Thanks for the reply.  I see now that I hadn't noticed the search function before, and as you say it seems others in my area are not experiencing this issue.  I am hardwired here, though I am one hop through an unmanaged switch to the Verizon provided router.  The same machine sees 90+ Mbps to the verizon speed test, so I assumed something on their end, but in the absence of supporting data from others in my area it seems I have a bit of a puzzle.  I may move some things around to get this particular machine connected directly to the Verizon router and see if that helps.




Link to comment
Share on other sites

Verizon's speed test also multithreads.  If you want TestMy.net to multithread for comparison toggle the option on the multithread speed test, you can then use the site normally and the download speed test and automatic speed test will be multithread also.


I'm curious to see what your results are using the multithread option.  Let me know after you've tested.

Link to comment
Share on other sites



I enabled multi-threading, and the results are pretty much the same.  I am going to leave it to test every 15 minutes or so and see if it is consistent through the night.


Incidentally, I just ran another test to the verizon speedtest, and get fast results.  It's odd, but now I am quite curious as well as irritated ;)







Link to comment
Share on other sites

Hey all,


SO finally had time to do something with this.  I wound up completely resetting my FIOS router to factory fresh and the problem went away.  I didn't have anything terribly odd going on with the router other than forwarding ssh to one of my linux servers, and no changes that I can think of which predated the problem.  Could have just been some pernicious bit rot.  I also find it odd that it would not have affected speed test to VERIZON speed test server, but it did affect others.  Anyway, setting up auto tests for every 4 hours to see if it hold.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...