Jump to content
Sean

Multithread mode test [STOP] and Express upload buttons are broken

Recommended Posts

When a multithread test is in progress, the [STOP] button does not work properly, bringing up a 'Secure Connection Failed' error screen.  When I hover my mouse over the [STOP] button...

Multithread_stop_button.png.8a175b2ee2c0cbddae6d601b80bb3c44.png

... the address shown in the status bar has a ':80' after the domain name:

Multithread_stop_button_port80.png.1bd35f334340db6d368ea9bbe634a624.png

 

It affects the mobile website also, again bringing up an error screen when I touch [STOP], with the ':80' clearly in the URL it tried loading:

Multithread_stop_button_mobile.png.cdf7b8049eac04041df6211de9ea0bce.png

 

This issue also affects the upload test on the mobile website when Multithread mode is enabled (left image).  The Express upload test also fails with Multithread mode enabled (right image):

Multithread_upload_test_port80.png.978cfe32d4b9f9822957d03cd0ac951f.pngMultithread_upload_express_error.png.999d2680992b7bbd5e40f9e134113265.png

Share this post


Link to post
Share on other sites

That's great - These seem to be working fine now. B)

 

I also noticed that after you switched to HTTPS, the multithread tests now only test with a single domain per server.  This threw up an interesting surprise with my 4G LTE connection on the Three network - It throttles per host.  Initially I wondered why my multi-threaded test results were much lower than recently, until I tried selecting more than one server. 

 

For example, I tried a handful of multithread tests in a row, selecting London, then Germany, then London+Germany, all with 25MB blocks.  I repeated this sequence three times to rule out a coincidence.  In the test results below, the red-highlighted lines indicate the tests I ran with London+Germany.  In the top result, I selected London+Germany+Miami+New York. 

 

5a46dffb6dd1c_TestMyTwoormoreservers.png.a5269cb8d2731f5a79789ead8e8d6e5f.png

 

In the past, I wouldn't have seen this as selecting a single server such as London resulted in testing across multiple domains such as oldtestmy.net, tmnstatic.com, testmercury.net, etc. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
Speed Test Version 15.9
© 2018 TestMy Net LLC - TestMy.net - Terms & Privacy
© 2018 TestMy Net LLC - TestMy.net - Forum - Terms & Privacy