Jump to content

My download speed is slow on Firefox browser but fast while using torrent why?


Recommended Posts

So I have plan of 25Mbps Upload and Download and I am based in India. But whenever I download videos on browser the speed is significantly slower then what I am paying for. I get speed of 450-500 Kbps. But while using bit-torrent to download my speed is upto 2.5-3.0 MBps(My true internet speed). I am using a firefox browser and have a Linux OS [Distro: POP_OS]. Oh also, while downloading movies/series on Netflix app the speed is good, I mean it takes about 3-4 mins to download a 1.5 or 1 Gb data.

 

Why is the download speed so different on a browser as compared to a torrent and app? Does this has to do something with websites?

 

Update:

I just wanted to confirm the download speed again and now the download speed is 3.0 to 4.5 MBps.

 

Edit:

I ran the speed test here on testmy.net with default settings and the download speed is 3.3Mbps and upload speed is 17.8Mbps. This speed test was conducted at the same time when my download was 3.0 to 4.5MBps (as mentioned above)

Link to post
Share on other sites
  • 4 weeks later...

Try using Chrome and see if it's better. I have been testing internet speed as well lately and the ISP service tech showed me that when using Chrome, I get the download speed I'm paying for, 100 Mbps. When using Firefox, the speed is half that usually. Both browser versions should be fairly up to date. I've also seen where some Windows update issues will cause a particular browser to slow down vs another and then the problem goes away with the next Windows update.

 

Seems this could be a never ending battle.  Good luck.

Link to post
Share on other sites

I agree w/Gregd74 in that Microsoft/Windows 10 has many issues and now they are releasing a new update with known flaws, at least the ones they acknowledge. In one of the updates of the kxxxxx1903 versions my Bluetooth stopped working or I should say was blocked from connecting because of security issues that didn't play well with Conexant and other communications drivers various makers. 7+ months and finally an update that fixed that. I got so frustrated I wanted to switch to Linux but just can't deal with felling like I was back in the 80's using DOS and keyboard characters of precise spacing, etc. just to do mundane things that now all I have to do is point and click w/a mouse. Such is Linux command line language sounding more like teenage slang w/funny-bunny sounding dare I say words/commands. more like a teenage slang. When you start using a dif. browser it takes a little time for it to pre-interpret your inferences of search words. Googles A/I is built on this thus the leader in A/I technology. Remember, Artificial intelligence is no match for Human Stupidity.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...