Jump to content
Sign in to follow this  
fashun_diva

IP Address Error/ Connectivity Problem

Recommended Posts

Hi,

Was hoping somebody could help me with the problem I'm having getting connected to the internet. When I try to repair my network connections, I get the following message:

Windows could not finish repairing the problem because the following action cannot be completed:

Share this post


Link to post
Share on other sites

Looks like you have a router (192.168.1.1).

Have you tried first just rebooting, or power cycling the router to see if it renews the IP.

And second, HOW did you contact Testmy.net?

Another connection?

Hmmm.

Edit: I know, has 2 PC's on a router. I would still re-boot the router b4 going 2 far.

Share this post


Link to post
Share on other sites

After power cycle: Check TCP/IP settings for connection with that adapter (make sure IP address is not hard coded):

--Local area connection properties --> highlight TCP/IP --> properties = obtain automatically for both

Restore TCP/IP if necessary

--Local area connection properties --> highlight TCP/IP --> install --> protocol, add --> click "have disk" --> type: "c:windowsinf", ok --> internet protocol, ok --> reboot

Otherwise, make sure that there are no conflicts AT ALL in device manager, check pinging ability (URL and IP, try 64.233.161.104 for google) to test if its only your browsing, make sure firewalls are off when renewing IP (is it DHCP error or socket error?) ... and good luck!

Share this post


Link to post
Share on other sites

HELP!

I have the exact same problem but I eventually assigned an IP address to my computer with my router. Now I can ping but my Internet Explorer isn't working!!

Any help would be greatly appreciated.

Thanks in advance.

Try pinging www.yahoo.com.  If you get replys your on line and its an explorer issue.  Are there any error messages associated with IE when you try to browse the net or first start it up?

Share this post


Link to post
Share on other sites

Here are some more details of my situation hopefully it sheds some light.  Lets see, I'm using the Netgear WGR614v5 wireless router with 2 laptops (one using Window XP Service Pack 1 (SP1), and the other with Windows XP Service Pack 2 (SP2)). I setup the WEP security.

The laptop with SP1 is working great wireless! Unfortunately, the one with SP2 is having problems. The wireless network connection shows excellent signal strength. I can ping but Internet Explorer isn't functioning.

As a side note, before I assigned the computer with an IP address it was having problems renewing the IP address and was showing little or no connectivity for signal strength. I disabled all firewalls and tried WinsockxpFix but didn't work. Once I assigned the IP address, ping is now working. Was that the right thing to do?

Not sure if I included all pertinent details. Any help would be greatly appreciated. Keep in mind one of my computers is working perfectly wireless.

I followed your post you directed me to but IE is still not working.  I included some details of the steps I followed.  Some didn't apply and have identified them accordingly.

Hello all!  I just thought I would write up a little bit of a walkthrough on connection for cable Internet. 

**Note: this is assuming you are running Windows XP**

B. NO BROWSING

-when you have a valid IP address but cannot open web pages

-test for browsing after each step

Step 1: Scan for viruses and spyware = I USED McAfee Internet Security and AD-AWARE.  Didn't perform the safe mode scan.

-hopefully you are running antivirus and spyware protection programs.

-be sure to run a full system scan, one program at a time, and do not perform any other operations while these are running

-if you feel comfortable, you can also try the scan in safe mode for a more thorough scan

-if there are untreatable files, contact the vendor of the software for technical assistance

- https://testmy.net/forum/t-3924  <-- check this out for more info

Step 2: Turn off firewalls and antivirus ==== MADE SURE THEY WERE DISABLED

-turn off XP firewall by clicking start, control panel (if it says "switch to classic view" then click there), open "Windows Firewall", turn off

-look to your system tray (the icons by the clock in the bottom right), hover over each icon, if it is a firewall or antivirus then right-click it and choose exit, shut down or disable

Step 3: Ping command ===  Ping did not work when I tried to ping www.testmy.net but it did work when I pinged 67.18.179.85 with no packet loss.  Neither worked in the address bar. When I entered www.testmy.net in the address bar, the "Page cannot be displayed" window displays. When I entered 67.18.179.85 in the address bar, "Internet Explorer could not open the search page" message box displays.

-click start, click run, type "cmd" without quotes

-in the command window, type with out quotes "ping www.testmy.net"

-if the ping goes through, there will be a "ping statistics" line.  look for packet loss, and high round trip times

-if the ping is ok (no loss), proceed to Step 4: Restoring Browser Defaults

-if the ping says "unable to resolve host" or has 100% losses, try to ping by IP address

  -type without quotes "ping 67.18.179.85", and check for packet losses

-if the ping by IP address is ok (no loss), try to browse by IP address: in the address bar of your browser, type 67.18.179.85...does testmy.net come up? If so, it is a DNS issue.  Proceed to Step 5: DNS Settings

-if ping by URL and ping by IP address both fail, proceed to Step 6: Restoring TCP/IP

Step 4: Restoring Browser Defaults

Restored defaults, still IE is not working.

**Note: these steps are for Internet Explorer 6 only**

-open Internet Explorer, click Tools, click Internet Options

-under the General tab:

  -click "Delete Cookies" and click "ok" to the dialogue box

  -click "Delete Files", put a check where it says "delete all offline content" and click "ok" to the dialogue box

  -click "Clear history" and click yes to the dialogue box

  -where it says "Days to keep pages in history" set it to 5 or less (the default is 20)

-under the Security tab:

  -click the "Default level" button

-under the Privacy tab:

  -click the "Default" button

-under the Connections tab:

  -make sure it is set to "Never dial a connection"

  -click the "LAN Settings" button, set it to "Automatically detect settings" and click ok

-under the Programs tab:

  -click the "Reset web settings" button, click "yes" to the dialogue box

-under the Advanced tab:

  -click the "Restore defaults" button

-click apply, then ok

-close and reopen Internet Explorer, test for browsing on a few different site

-if still no browsing, continue to Step 6: Restoring TCP/IP

Step 5: DNS Settings

**when you can browse by IP address, but not by URL**

-click start, control panel, switch to classic view, open "Network Connections"

-if you are hard-wired, look to "Local Area Connection"; if you are wireless, look to "Wireless Connection"

-right-click your connection, choose properties

-under "this connection uses the following items" click to highlight "Internet Protocol (TCP/IP)"

-click properties

-set to: "obtain DNS server address automatically"

-test browse to "testmy.net" (try others also)

-if you still cannot browse by URL, continue to next step, otherwise contact your ISP to check for DNS issues

Step 6: Restoring TCP/IP === Restored them!

-click start, control panel, switch to classic view, open "Network Connections"

-if you are hard-wired, look to "Local Area Connection"; if you are wireless, look to "Wireless Connection"

-right-click your connection, choose properties

-click install

-choose protocol, click add

-click "have disk"

-where it says "copy manufacturer's files from" type without quotations "c:windowsinf" then click ok

-choose "Internet Protocol (TCP/IP)" and click ok

-close windows and restart computer

Share this post


Link to post
Share on other sites

Cool, good job there.  Ok cromob, can you consistently ping by IP address (try google's: 64.233.161.99  or yahoo's: 68.142.226.33)?  Be sure to look in the "ping statistics" line and make sure it says:

Ping statistics for 68.142.226.33:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

...stressing the 0% loss.

If you can ping by IP but not by URL (ie. www.yahoo.com) then it is a DNS (domain name server) issue.  Check it: each computer on a network is located by IP (Internet Protocol) address, but since it is too hard to remember 64.233.161.99 and much easier to remember google.com, the DNS was designed to convert URL (Uniform Resource Locator) to the corresponding IP address of that computer.  Much easier.

Ok enough bore.  Sometimes, as I have seen with XP, when you specify the IP, windows automatically assumes that you will also specify the DNS server.  Most of the time, DNS should be obtained automatically, but now that you specify the IP it won't let you choose that option.

Go to: control panel --> network connections --> right-click wireless connection, choose properties --> click to highlight 'Internet Protocol (TCP/IP)' --> click propterties:

-you'll see that your IP is being manually specified

-is there a dot next to 'obtain DNS server address automatically' ?

-if not, can you put one there?

-do you need to set it to 'obtain IP address automatically' in order to do so?

Please post back, as I am very curious if this is the case here.

One last thought: make sure that "generic host" isn't being blocked in the program control of your firewall(s).  For ZoneAlarm:

        -click 'program control' on the left side menu

        -click the 'programs' tab on the top

        -look for 'generic host' in the list of programs

        -make sure that it is checked/allowed all the way across

Share this post


Link to post
Share on other sites

Hey FallowEarth,

I actually ended up using the RapidRestore feature on my laptop, burned all of the files I created/updated since I setup the restore point which was just about 3.5 months worth (700 mb).  From that point it was smooth sailing!  Success!! 

Thanks alot for taking the time to help me out, you are the man!!

Share this post


Link to post
Share on other sites

FallowEarth,  No, I didn't even have to specify an IP address it obtains it automatically now.

s1,  My router doesn't have a setting for the number of client IP's.....but it works now that I used  the restore point. Didn't even have to change a setting on my router!!  Thanks for the input though.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...