Jump to content
Sign in to follow this  
wyantm06

Laptop Battery Question...

Recommended Posts

I know I am probably the most annoying person on this board lol but this place brings joy to me, mostly because everyone shows respect. But here is my question. I thought my battery was junk the whole time in my laptop. But I just finally found out I was wrong. A display came up saying my battery is low, well my battery down in the bottom has been at 0% for about 10 minutes. Btw I have a Dell Latitude C810. Is there a drive I am suppose to download to get this to work right or something? Thanks so much! Happy holidays to all...

Share this post


Link to post
Share on other sites

You shouldn't need any drivers for the battery. Are you saying the meter show 0 percent yet you've been running for 10 minutes. The meters are never perfect and might say 0 while there is still some battery left to give you a chance to save/plug in. Try charging it fully and see how long it lasts and if the reading seems accurate.

You're not annoying, you just need a lot of help, but at least you ask questions  ;).

Share this post


Link to post
Share on other sites

You shouldn't need any drivers for the battery. Are you saying the meter show 0 percent yet you've been running for 10 minutes. The meters are never perfect and might say 0 while there is still some battery left to give you a chance to save/plug in. Try charging it fully and see how long it lasts and if the reading seems accurate.

You're not annoying, you just need a lot of help, but at least you ask questions

Share this post


Link to post
Share on other sites

Alright lol! Still running on 0%! I am pretty sure it is supposed to stay at like 0% for like 2 minutes so you have enough time to plug the power cord in. Well I am on like 16 minutes. The low battery thing is flashing and everything underneath the screen and the right hand corner says my battery is dead. So I don't know lol. Thanks you been lots of help.

Share this post


Link to post
Share on other sites

Oh also if I plug in my power cord and take the battery out it has a power tester on it and it says dead on that to. Wow this is weird. Everything I check it says it is dead, but it's working still? Hmm I will have to update you in a few hours. I will leave it on while I sleep and see if it is on still when I wake up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...