Jump to content
raptor20561

help!!! half duplex reported? flow control limits? throughput limits?

Recommended Posts

just wondering is this a problem? my connection is 6 down 768 up, check out the bottom of the report from the UCSC server i made the important parts bold and red for easy viewing ^^

btw running win 2000 pro and a router

Another client is currently being served, your test will begin within 45 seconds

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 948.75Kb/s

running 10s inbound test (server to client) . . . . . . 5.10Mb/s

Your PC is connected to a Cable/DSL modem

Alarm: Duplex mismatch condition exists: Host set to Full and Switch set to Half duplex

click START to re-test

Checking for Middleboxes . . . . . . . . . . . . . . . . . .  Done

running 10s outbound test (client to server) . . . . . 950.27Kb/s

running 10s inbound test (server to client) . . . . . . 5.01Mb/s

Your PC is connected to a Cable/DSL modem

Alarm: Duplex mismatch condition exists: Host set to Full and Switch set to Half duplex

WEB100 Kernel Variables:

Client: localhost/127.0.0.1

AckPktsIn: 690

AckPktsOut: 0

BytesRetrans: 0

CongAvoid: 0

CongestionOverCount: 0

CongestionSignals: 0

CountRTT: 564

CurCwnd: 65700

CurMSS: 1460

CurRTO: 300

CurRwinRcvd: 64240

CurRwinSent: 5840

CurSsthresh: 2147483647

DSACKDups: 0

DataBytesIn: 0

DataBytesOut: 6278000

DataPktsIn: 0

DataPktsOut: 4300

DupAcksIn: 125

ECNEnabled: 0

FastRetran: 0

MaxCwnd: 65700

MaxMSS: 1460

MaxRTO: 320

MaxRTT: 160

MaxRwinRcvd: 64240

MaxRwinSent: 5840

MaxSsthresh: 0

MinMSS: 1460

MinRTO: 230

MinRTT: 30

MinRwinRcvd: 64240

MinRwinSent: 5840

NagleEnabled: 1

OtherReductions: 0

PktsIn: 690

PktsOut: 4300

PktsRetrans: 0

X_Rcvbuf: 103424

RcvWinScale: 2147483647

SACKEnabled: 3

SACKsRcvd: 0

SendStall: 0

SlowStart: 43

SampleRTT: 100

SmoothedRTT: 100

X_Sndbuf: 103424

SndWinScale: 2147483647

SndLimTimeRwin: 9226440

SndLimTimeCwnd: 782701

SndLimTimeSender: 2890

SndLimTransRwin: 1

SndLimTransCwnd: 1

SndLimTransSender: 1

SndLimBytesRwin: 5856060

SndLimBytesCwnd: 421940

SndLimBytesSender: 0

SubsequentTimeouts: 0

SumRTT: 55570

Timeouts: 0

TimestampsEnabled: 0

WinScaleRcvd: 2147483647

WinScaleSent: 2147483647

DupAcksOut: 0

StartTimeUsec: 321797

Duration: 10025144

c2sData: 2

c2sAck: 2

s2cData: 8

s2cAck: 3

half_duplex: 0

link: 100

congestion: 0

bad_cable: 0

mismatch: 1

spd: 0.00

bw: 113.05

loss: 0.000001000

avgrtt: 98.53

waitsec: 0.00

timesec: 10.00

order: 0.1812

rwintime: 0.9215

sendtime: 0.0003

cwndtime: 0.0782

rwin: 0.4901

swin: 0.7891

cwin: 0.5013

rttsec: 0.098528

Sndbuf: 103424

aspd: 5.77794

Checking for mismatch on uplink

(speed > 50 [0>50], (xmitspeed < 5) [0.95<5]

(rwintime > .9) [0.92>.9], (loss < .01) [1.0E<.01]

Checking for excessive errors condition

(loss/sec > .15) [1.0E>.15], (cwndtime > .6) [0.07>.6],

(loss < .01) [1.0E<.01], (MaxSsthresh > 0) [0>0]

Checking for 10 Mbps link

(speed < 9.5) [0<9.5], (speed > 3.0) [0>3.0]

(xmitspeed < 9.5) [0.95<9.5] (loss < .01) [1.0E<.01], (mylink > 0) [3.0>0]

Checking for Wireless link

(sendtime = 0) [3.0E=0], (speed < 5) [0<5]

(Estimate > 50 [113.05>50], (Rwintime > 90) [0.92>.90]

(RwinTrans/CwndTrans = 1) [1/1=1], (mylink > 0) [3.0>0]

Checking for DSL/Cable Modem link

(speed < 2) [0<2], (SndLimTransSender = 0) [1=0]

(SendTime = 0) [3.0E-4=0], (mylink > 0) [3.0>0]

Checking for half-duplex condition

(rwintime > .95) [0.92>.95], (RwinTrans/sec > 30) [0.1>30],

(SenderTrans/sec > 30) [0.1>30], OR (mylink <= 10) [3.0<=10]

Checking for congestion

(cwndtime > .02) [0.07>.02], (mismatch = 0) [1=0]

(MaxSsthresh > 0) [0>0]

estimate = 113.05 based on packet size = 11Kbits, RTT = 98.53msec, and loss = 1.0E-6

The theoretical network limit is 113.05 Mbps

The NDT server has a 101.0 KByte buffer which limits the throughput to 8.00 Mbps

Your PC/Workstation has a 62.0 KByte buffer which limits the throughput to 4.97 Mbps

The network based flow control limits the throughput to 5.08 Mbps

Client Data reports link is 'T1', Client Acks report link is 'T1'

Server Data reports link is 'OC-48', Server Acks report link is 'Ethernet'

Share this post


Link to post
Share on other sites

hey raptor20561  and welcome to the forum :)

that duplex mode test is not accurate

it read my line as half duplex even tho i know for sure its full duplex

as long as you have good speed, do not worry about that

when using a router, you should use 100 Mbps full duplex on your NIC, and leave all other NIC settings as default

VanBuren :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...
Speed Test Version 15.9
© 2019 TestMy Net LLC - TestMy.net - Terms & Privacy