Jump to content
cbtshare

website issues

Recommended Posts

Bless ppl,

              I have a website built in perl.I'm running it on apache 2.I have installed the site and databases properly ,the html files are ina a folder in the native CGI folder in apache called Templates.When I go to my website address the site is suppose to show up, but it doesnt, I have to go to www.myaddress.com/cgi-bin/index.cgi for the index file of the website to show.I have this httaccess file also that should map everything

RewriteEngine on

RewriteCond %{HTTP:Authorization} ^(.*)

RewriteRule ^(.*) - [E=HTTP_CGI_AUTHORIZATION:%1]

RewriteRule    ^$ /cgi-bin/index.cgi [L]

RewriteRule    ([0-9A-Za-z]{12})-del-([0-9A-Za-z]+)/.+$ /cgi-bin/index.cgi?del=$1-$2 [L]

RewriteCond %{REQUEST_FILENAME} !-f

#RewriteRule    ^([0-9A-Za-z-_]*)/?([0-9A-Za-z]{12})(.html?|$)$ /cgi-bin/index.cgi?op=download1&usr_login=$1&id=$2 [L]

#RewriteRule    ^([0-9A-Za-z-_]*)/?([0-9A-Za-z]{12})/([^/]*)(.html?|$)$ /cgi-bin/index.cgi?op=download1&usr_login=$1&id=$2&fname=$3 [L]

RewriteRule    ^([0-9A-Za-z]{12})(.html?|$)$ /cgi-bin/index.cgi?op=download1&id=$1 [L]

RewriteRule    ^([0-9A-Za-z-_]*)/?([0-9A-Za-z]{12})(/[^/]*|$)(.html?|$)$ /cgi-bin/index.cgi?op=download1&usr_login=$1&id=$2&fname=$3 [L]

RewriteRule    ^checkfiles.html$ /cgi-bin/index.cgi?op=checkfiles [L]

RewriteRule    ^contact.html$ /cgi-bin/index.cgi?op=contact [L]

RewriteRule    ^premium.html$ /cgi-bin/index.cgi?op=payments [L]

RewriteRule    ^login.html$ /cgi-bin/index.cgi?op=login [L]

RewriteRule    ^catalogue(.*).html$ /cgi-bin/index.cgi?op=catalogue&date=$1 [L]

RewriteRule    ^news([0-9]*).html$ /cgi-bin/index.cgi?op=news&page=$1 [L]

RewriteRule    ^n([0-9]+)-.*.html$ /cgi-bin/index.cgi?op=news_details&news_id=$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule    ^([0-9A-Za-z-_]{4,64})(/[^/]*/?|$)$ /cgi-bin/index.cgi?op=user_public&usr_login=$1&fld=$2 [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule    ^([a-z0-9-_]+).html(.*) /cgi-bin/index.cgi?op=page&tmpl=$1$2 [L]

ErrorDocument 404 /404.html

but it doesnt work.

Help anyone

Share this post


Link to post
Share on other sites

×
×
  • Create New...