Jump to content
Sign in to follow this  
fergy623

xplornet users, Lets see if we are at where we what to be!

Recommended Posts

If you are a xplornet user and are a wireless customer as I am lets chat and see if you are content with your speeds and service. I am just curious if you other xplornet customers are getting what you pay for or do you really know where you stand! My speed tests are here. https://testmy.net/tools/database/personal_stats_30d.php?user_name=fergy623&m=04&d=05&Y=2006 and I am paying for the business package that is 5.0 Mbps down and 1.5 Mbps up and I find that xplornet support has some of the knowledge and the installers have minimal knowledge. What do you think and please show your speeds?

Share this post


Link to post
Share on other sites

ah yes, the advertised speed verses real speed at Xplornet wireless.  Here is the scope from one of the 2nd level support people who was actually honest.  If you have 3 meg download the real sustained download speed is set to 800kbps and that's it.  Let's just say far short of what they advertise and what you pay for.  If you have the 5 meg package they bump you up to 1000 kbps, or about 1/5 th of advertised speed.  I guess either we live with their BS or switch to someone else if that is an option.  I know at my speed of "3 meg download" I usually get well under 800kbps but at 5 in the morning it works much better.  There service is way oversold at the tower I am connected too!

Share this post


Link to post
Share on other sites

I knew that somewhere, someone would respond and am glad you did as I thought maybe I was the only person on xplornet that was involved in speed tests or was at least concerned as to what I am paying for. Good to see that you are involved as well. I am from Red Deer, Alberta

Share this post


Link to post
Share on other sites

Ive got the KaBang (sorry, not wireless) service from Xplornet (1024/256) and we're paying 89.95 a month. What a complete ripoff! The service sucks, the speeds suck (we get about half of advertised, and upload is always at 4k/s), it takes forever to get through to tech support, and they never have an answer. Bah.

Share this post


Link to post
Share on other sites

yes tech support sucks, I spent almost 20 hours in one month on hold only to be told lies, It turns out they were doing upgrades to the tower iwas on, If they had told me that at the begining of teh issue I would have cuthemsome slack, I have told everyone thatsks me about it haw bad their tech (support)  is. Notice i put support in brackets because there wasn't any. as soonas hydo one finshes ther new high speed in this area I'll be gone from xplornet. bell is also looking at upgrading lines in the area to offer dsl. once bell upgrades the lines, i will get the discount dsl from ontario dsl that i bought for my parents 3 megs for like $20 a month. speed tests always check in the high 2's to mid 3's

Share this post


Link to post
Share on other sites

I've got the KaBang as well. Supposed to be 1 Mbps down and 256 Kbps up.  Not a chance.  Usually half that or less.  A lot of stalls and disconnects.  I wouldn't recommend it for the money.  Not only the monthly fee, but you have to pay an arm and a leg for installation and the equipment.  Anytime I call tech support, they do nothing to help.  Is there any way to get better service out of these guys?

Share this post


Link to post
Share on other sites

Just got off the phone with Telus and they will have DSL in my area within 2 months.  That means that Xplornet will only have my business for 2 more months!!!  Thank God!!!  Nothing worse than crap service.  It seems that's the only kind you get in Alberta!!!  Kills me to have paid $800 for equipment and installation.  I'll never have anything good to say about Xplornet.

Share this post


Link to post
Share on other sites

I have the satellite internet from Xplornet.  Had it for months now.  I called tech support last night because I kept getting dissconnected.  There has not been a single day that I've had a constant connection.  This time they said I got FAPed.  This is a load of bull.  I monitor my data transfer and it was no where near the 169MB limit.  Tried the modem, tried the anit virus, tried the spyware, took my computer to work with no probems.  They have a list of excuses to get rid of you.  Don't buy it.  If you're having constant problems, it's on their end but they won't admit it.  I've troubleshooted ever possible scenario and it all boils down to them having crap service.  I am expecting a "LEVEL 2" call today because I stumped the "LEVEL 1" guy last night.  I will keep everyone posted and I will continue to spread my story until I am satisfied with their service or get a refund on the $800 installation and equipment charge.  There are employees of Xplornet that post here as well and they have nothing but good things to say.  Do your research people.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...