Jump to content
CFernando17

What is the best site for checking packet loss?

Recommended Posts

Hello everyone, 

     I've recently started seeing a variance in packet loss on my Xbox One over the past 2 weeks and I'm trying to figure out the cause. My ISP is Comcast XFinity and I'm on the 105mbps/10mbps plan. I have an Arris SB6183 Modem hooked up to my Netgear Nighthawk R7000 (AC1900). My Xbox is hardwired. As far as my speeds go, everything tests ok. Both on this site and on my Xbox One. My NAT type on the Xbox is OPEN. The Detailed Network Statistics on my Xbox One shows Download speeds of 118mbps Down and 11mbps Up. The Latency shows 65ms (which is good). The MTU Size is 1480, which is fine as well. The issue is when I take a look at the packet loss, which shows I'm getting either 1 or 2% packet loss:icon_scratch:. Now, I've tried using both Cat5 and Cat6 ethernet cables and it makes no difference. I've also tried connecting my Xbox through WiFi but the packet loss is still there. I've ran an ethernet cable straight from my Arris SB6183 modem to the Xbox, same thing. I've even tried using the gateway Comcast provides to see if my modem was the issue but to no avail. The packet loss remains. Next, I took in my Xbox One to Best Buy and swapped it for an Xbox One Elite through the 2 year protection plan I had on it, thinking that my Xbox might be the culprit. I get home, excited to use my new Elite controller and convinced that I was finally in the clear...BAMMM the Xbox Network tests hit me in the face with a 1% packet loss yet again!:angry4: 

I've tried port forwarding, tried changing the MTU Size, giving the Xbox One a static IP address, putting the Xbox in DMZ Mode, turning on UPNP, turning off UPNP, turning on QoS, turning off QoS, etc but the packet loss never clears. As I mentioned before, this began happening about 2 weeks ago. I started noticing a big difference in online gameplay on my Xbox One so i ran the Network tests. That's when I first noticed that I was getting that 1% packet loss. Before that, I'd have 0% packet loss every time. Yesterday I brought my Xbox over to a friends house to test it with his connection and guess what I saw? Yep, you guessed it 0% packet loss! So it's definitely an issue with my connection and nothing to do with my Xbox itself. 

If anybody has knowledge or tips they wouldn't mind sharing with me, I'd really appreciate it. Also, if anyone knows the best method or the best site for testing packet loss please let me know. I wish I had the option of going with Verizon FiOs or Google Fiber but they don't cover my side of the Houston area. Thanks for reading and thanks for the feedback ladies and gents! Have an awesome day:occasion14:

Share this post


Link to post
Share on other sites

The best place to test for packet loss is on your computer.  Most websites that test for packet loss run the test on their server, which is basically to test the host end for packet loss rather than your connection.

 

Like speedtest.net, I never had much luck with pingtest.net either as I've run tests on a line that was giving a fairly consistent 7% packet loss and pingetest.net either failed to load or reported 0% packet loss. :huh:

 

I wrote the following script which measures packet loss against Google's DNS server.  Copy & paste the code into Notepad and save it as "pingtest.bat" on your desktop.  To run the script, just double-click the pingtest icon.

 

@echo off
set /a PingCount=0
set /a PacketsLost=0
set tensec=%time:~6,1%

:pingrepeat
ping -n 1 8.8.8.8 >null &&goto pingreply
set /a PacketsLost+=1
:pingreply
set /a PingCount+=1
set /a Complete=PingCount/10
if not "%time:~6,1%"=="%tensec%" (
  echo Test %Complete%^%% complete...
  set tensec=%time:~6,1%
)
if not "%PingCount%"=="1000" goto :pingrepeat

set /a PacketLoss=PacketsLost/10
echo Packet loss: %PacketLoss%.%PacketsLost:~-1,1%^%%
echo.
pause

The script can take a few minutes to complete and shows a progress percentage roughly every 10 seconds.

 

While it's also possible to run this test by typing "ping -n 1000 8.8.8.8" at the command line, normally the ping command waits 1 second per ping, which would take 15 to 20 minutes to complete. 

Edited by CA3LE
changed "nul" to "null"

Share this post


Link to post
Share on other sites

 

CFernado17

 

I am on XBOX ONE Time Warner Cable 60/6.  I have been having the same problems as you.  And it started at about the same time.   I've done everything you've done and still can't shake the 1% on the XBOX test.  On PC doing all the command prompt things, pingtest.net and using wireshark I can't see where there is any packet loss.  There was an XBOX ONE update on 1/11/2016  I'm not sure if that had anything to do with it.  If you find a solution please post here or McKillKill on Xbox Live.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...