Jump to content

reCaptcha stuck in a loop in Firefox 67 (beta) + Workaround

Recommended Posts

Up until recently reCaptcha has never given me any bother, except occasionally when using over a shared network such as cellular data or a privacy VPN.  Just recently while on a reCaptcha protected form, I ticked the "I'm not a robot" and got a puzzle.  Usually, it's just a matter of solving it and lets me proceed.  This time, it gave me another puzzle to solve, followed by another and so on.  After solving something like 10 puzzles I tried the audio challenge, only to be told that I cannot use this option due to sending automated queries. :angry:


I checked with another IP address (e.g. rebooting router) in case I was assigned a blacklisted IP, but still faced the same issue with reCaptcha.  After some searching online and finding plenty others in the same situation, I came across a discussion with a few mentioning to try Chrome.  Sure enough, when I tried the same page in chrome, I got the green tick without having to solve anything.  So this rules out my network and pointed the issue to Firefox. 


It then hit me that one of the new features with Firefox 67 beta is that it blocks tracking cookies by default, which you can see by clicking the circled 'i' to the left of the address bar:



To test this, I went to a Whois page on a domain registrar (which are usually reCaptcha protected), typed in testmy.net and sure enough when I ticked reCaptcha, it gave a puzzle:



I then turned off blocking on the site (grey button in first screenshot above) and refreshed the page.  When I ticked the box again, I got the green tick without any puzzle. ?



As far as I'm aware of, the stable Firefox releases are not affected unless you turn on content blocking.  For example, on my laptop, I got the green tick straight away in Firefox 66, but when I tried in Firefox 67b with tracking cookies blocked by default, reCaptcha gave me a puzzle.


reCaptcha tip

Before potentially wasting time on what could be an endless loop, click the 'Headphones' icon underneath:


If it tells you that the audio challenge is not available, then do not attempt to solve the puzzle either.  From my experience above and having reCaptcha issues before with a blacklisted IP on a privacy VPN, if reCaptcha does not offer an audio challenge, then it almost certainly will deliver an endless number of puzzles to solve, i.e. there's no getting past without trying something else such as a different network.

Edited by Sean
Broken image
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...