Jump to content

Setting up a cron for rsync on a non conformant port


Recommended Posts

I've been mirroring files from a remote server to a local server, always always have a backup. Using the following

rsync -avz -e 'ssh -p xxxx' [email protected]:/var/ /var
Typing it in is not an issue, if i remember to do it every few days. I know I need a key to allow the cron access , or not ask for a password each time defeating the automated process. Iv'e made my key on the local server and tried uploading it to the remote server
scp /root/rsync/key.pub [email protected]:/root

Which fails due to not being on port 22

So thats actually where I'm stuck. I know I need to specify the proper port , and have tried several things but it always fails, I'm obviously not getting it right.

Link to comment
Share on other sites

Isn't that always how it is??

With me it is. I'm always looking deeper into what I may have borked . You would think i might learn to just take a step back and look at the surface.

Everything running as it should. Iv'e set up a local snap server using rsnapshot. Now to redo it all on that 1650 running raid 1 mirror, and include the entire server with databases.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...