Jump to content
Sean

Multithreaded test intermittently running linear tests

Recommended Posts

This morning, I noticed that roughly every second multithreaded test I do ends up running a linear test. 

 

Just in case it was a cache/cookie issue or with Firefox, I tried again in Chrome after clearing my cache & cookies and it did the same thing as shown in the following screenshots:

 

For example, I start by choosing the Multithread option and picking London UK:

 

Multithread_selection.png

 

I then click Save and go into start a 25MB download:

 

testmy_1.png

 

It then shows a screen as if I'm running a linear test and even suggesting I try the multi-threaded test:

 

testmy_2.png

 

After the test completes, it shows the variation in the throughput throughout the test exactly like if I ran a linear test, yet shows the lightning bolt in the result line showing that I ran a multi-threaded test:

 

testmy_3.png

 

Finally, when I switch back to Linear test mode, it defaults to the Texas server.  Normally it defaults to the London UK one which is nearest to me:

 

testmy_dallas_default.png

 

Going a little off topic here, but when I went to make this thread, I noticed that the forum will not let me upload images either.  The images in this post are on my own host as I couldn't upload them.

 

testmy_upload_fail.png

 

Sure is a strange morning even back at home.  I noticed that I could not connect to either of my Internet connections (DSL or fixed wireless.)  :huh:  The router for the fixed wireless crashed (a reboot fixed that) and one of the HomePlug adapters for the DSL has died.

Share this post


Link to post
Share on other sites

Yesterday I made it so that if you're selected on a different server than you actually initiate a test on, it automatically switches your settings to the server you're testing from.  I happened to forget about multithread, which internally is handled a little different.  Correction has been made and it shouldn't have that issue again.

 

I also test posted a couple of images.  Under my own account and under a test account with regular privileges.  I was able to post images without problems... the first time.  Then when I retried with the flash uploader it didn't work... switched to the basic uploader and it worked.  I have no idea why the flash uploader wouldn't work all of a sudden but I'll look into it.  This is why there's a backup basic uploader (link right below the attach button), because flash is stupid.  :tard:  -- funny thing is, first two times I tried, it worked... it wasn't until after a preview was posted that it broke. (sigh, I'd rather that it was just broken... much harder to figure out when it works sometimes.)

 

post-2-0-62434200-1439646181_thumb.jpg

 

I'll either fix it or make the basic uploader default.   ... I'm working on a new forum anyways, IPB (the forum software used now) is probably on its way out.

 

Thank you for reporting this.  Please keep your eyes out for anything else out of the ordinary, I'm currently making improvements.  First with things in the backend that you may not notice, then as time goes on the changes will be more noticeable. 

Share this post


Link to post
Share on other sites

Unfortunately it's still doing this intermittently on my end, including on my mobile browser.  I tried again after clearing my cache and cookies.  Like earlier, it sometimes does the multi-threaded test and other times does a linear test.

 

The following is an example on my mobile which I did while out shopping where I have 3G coverage, i.e. I went into the Multithread test mode and touched "Express Multithread" and it proceeded to do a linear test.

 

post-248268-0-14070800-1439667235.png post-248268-0-67959200-1439667240.png

 

Like the PC test, it showed the lightning bolt for the test result, but a speed graph like for the linear test.

 

post-248268-0-74295200-1439667502.png khN91b8W.png

 

Forum uploads worked this time. :wink2:  I'll try the basic uploader if it gives a problem again.

Share this post


Link to post
Share on other sites

Unfortunately it's still doing this intermittently on my end...

 

I see what you're saying.  I guess there was a dual issue.  When I hit retest on the auto test each time it flopped back and forth :-P -- linear, multi, linear, multi -- give it a try again, should be resolved.   ... that is, unless there's a third way I messed it up.

Share this post


Link to post
Share on other sites

I tried a handful of tests between my PC and mobile and this time it seems to be resolved.  :cool:

 

Like my home fixed wireless ISP, the Three 3G and LTE networks both need a multi-thread test to check the full capacity available.  I assume they throttle linear transfers to reduce network usage such as force streaming TV to use a lower bitrate as I've never seen a linear test show anything faster than about 10Mb even on 4G.

 

The Meteor 3G network doesn't seem to do that, which I'm currently trying out with a prepay SIM.  I get roughly the same speed whether I use linear or multi-threaded tests and their 3G linear speed is sometimes faster than a multi-threaded test on Three's LTE network.  :smiley:

 

C82zb7cM.R1o7IfJ.png dPFOR3Mt.xGUacO3.png

 

I would be curious to see what Meteor's 4G would achieve, but they charge €20 for 4G compared to €10 for their 7.5GB add-on and their nearest 4G coverage is also a 1.5 hour drive from home.

Share this post


Link to post
Share on other sites

×
×
  • Create New...