Jump to content

Oddly (ridiculously) high result


Recommended Posts

Hi,

I had some bandwidth issues the other night; been on NBN (Australia) for about 3 weeks with a 100/40 plan, and I was seeing sub 10Mb on the download side using the official speed test app.  I had noticed because Netflix looked poor quality.  I failed to do a test using a wired device (doh!).

Anyhow, next day I thought - wouldn't it be nice to automate a regular test so I could have some history?  And google brought me here :)   I didn't even need to create a script, awesome!

 

I'd like to measure both locally and overseas, and that's where I got stuck.  The multithread option didn't seem to do what I expected;  i.e., measure more than one destination in a reportable manner so I could see over, say, a 24 hr period how the bandwidth looked like to London, or US central.  Instead it seems to aggregate into an unsplittable result.

I then tried multiple browsers tabs, only to find they shared the destination info.   Two different browsers - same.

 

So I've ended up with;

Running a local (Sydney) test on my PC

Running a UK test on another PC - with it NOT logged in else it ends up with both PC's doing the same destination.

 

So question 1:  Did I misunderstand the multithread and would it give me what I want?  (graphs for Sydney, graphs for UK, and graphs for US)

 

On my UK test, I'm getting odd results.  Min 87Mb, middle 156Mb, Max 657Mb.  The Sydney test (94Mb) proves I'm not suddenly getting a Gb connection :D  It *looks* like caching to me, but I thought I read the data was randomly generated each time?

 

So question 2:  What could be some reasons that a test would imply speeds far exceeding my connection speed?

FWIW;  yes, I have a proxy in between.  I'm running Sophos UTM - however, even that *was* caching, it should be irrelevant when the data is randomised shouldn't it?  And I don't get the odd results for the Sydney tests.

 

thanks

Dave

Link to post
Share on other sites

In short, it's your Sophos UTM:-P  -- do you have an appliance or their free software?

 

An example of the result you're referring to.

 

TestMy.net Test ID : C9WHB9BLV

 

Those measurements taken during the test (TiP) can be misreported if there's a glitch during the test.  This could be a glitch with the browser or with extensions of the browser.  Probably during the loading of the test data something caused a slight pause in the processing.  This pause can manifest in a decrease of time because it messes with the test's timing events.  If it were an issue with caching... your result overall would be off the chart.  The largest test would complete in a fraction of a second and the TiP graph would be a flat line.

 

Good thing is that those TiP numbers have no effect on the overall calculation of the result.  The TiP and the final speed are calculated from separate timing events.  It's there for reference but if you see obviously wrong numbers it's probably client-side software related, not actually going that fast.  Take that information with a grain of salt.

 

Software that acts as a proxy and proxies have been known to do this too.  When you add something between that pre-processes and a delay occurs in the process it seems to manifest as an increase in speed.  Caching is probably not happening though.  The way the single thread test flows... it either would need to cache all or nothing.  Would be extremely obvious if it cached.

 

I think that if you see something like that... it happened for a reason.  It is most likely, at least in small part impeding the normal flow of bytes.  Especially if you see an erratic progress bar.  

 

Why does this not happen against the closer AU server in your case?  I'm not quite sure.  But if you disable Sophos and re-run the UK test, I'd bet it no longer does that.

 

Keep in mind that all of the test servers have identical software and configuration, they all report to the same master server for updates.

 

The multithread test is able to test against more than one server at a time but it still displays only one result.  If you'd like graphs of all the different test locales you'll need to test them individually. 

Link to post
Share on other sites

I'm using the software version running as a VM.

 

I've tried disabling the proxy part of it and got a similar result.  So now I just fired up another VM and bypassed the UTM entirely  (to 'force' traffic the UTM, I put everything on a different network with the UTM having the route to the router) by being on the same network as the router and using the router as the default gateway.  I still got a 'max' of 174Mb to the UK

https://testmy.net/db/32FuiQXIr

 

You may notice I also swapped ISP's, so I've ruled out there being something 'odd' in the AussieBB network, since Superlook gets similar (thought not as ridiculous) results. 

 

What I have noticed, is that running on my main PC I don't see greater than 100Mb - at least not so far.  So *maybe* the other PC I was running the GB test from was maxing CPU and that causes some timing issues which affects the result?  Presumably the VM could be the same

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...