Jump to content
Sign in to follow this  
ArcticWolf

Can't change MTU

Recommended Posts

No matter what program I try my MTU won't change.... I set it to 1492 cause I'm using PPPoE DSL..... but as I mentioned that no matter what program I use it won't stay at 1492 it goes back to 1452 according to the tcp/ip analizer at SpeedGiude.net, anyone have a fix for this or know where in the Win98se registry when I can set this manually.

Thanks

Share this post


Link to post
Share on other sites

Yes I am sure it's MTU , I'll copy and paste what I got from SpeedGuide.net

MTU = 1452

MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.

MSS = 1412

MSS is not optimized for broadband. Consider increasing your MTU value.

Share this post


Link to post
Share on other sites

ArcticWolf  ~ this is where you find the settings in Windows XP, I'm not sure if it's the same for Win98se ~ but you can look to see.

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServices

  TcpipParameters

just make sure you use HEXIDECIMAL base [if and when you change things]

MTU    REG_DWORD      0x000005d4 (1492)

look in Interfaces while your there, too.

Share this post


Link to post
Share on other sites

ArcticWolf: I did this a whie back but I beleive it will let you make the MTU 7 MSS settings in the Windows 98se registry.

--------------------------------------------------------------------------------

This is how my Windows 98 SE& windows ME are tweaked.You need to determine what RWIN ,MTU,&MSS your OS needs to use .Then you

can add them to your registry .

These tweaks will allow you to make some adjustments to your system if you want to do it yourself.There are programs that

will do this for you.

Like Cablenut but it won't make all of these.If you use one of these this will allow you to see if the program made these

adjustments to your registry.If you don't like the adjustment a program made you can change it

back if you don't like adjustments to the program you are using to automatically make the adjustments

for you.Some allow ajustments some do not.Since I can't know what you have installed you will have to

decide what it will take for your OS to keep the settings you want.

You need to install this patch

http://dslnuts.com/patch/236926usa8.exe It might already be installed or you might be able to get it from MS .

This is the MS link  http://support.microsoft.com/default.aspx?scid=kb;en-us;236926

  These tweaks are for setting your RWIN(DefaultRcvWindow),MTU&MSS.You need to determine yourself what

settings your OS needs.

  You need to have window scaling turned on if you want a larger RWIN than 65535 windows 98se will

automatically limit the maximum to this with window scaling off even if you set it larger.To determine this

you need to go here in your registry.HKLMsystemcurrentcontrolsetservicesVxDMSTCP there should be a string value

here "Tcp1323Opts" Exactly like this without the quotes.The O is the letter not a zero. Capital letters should be

as they are here& small letters as they are.This is important when tweaking the registry with any tweaks you might

add.If this setting is not here you need to add it as a new string value.The values are 0(zero) for Window scaling off,

1 for window scaling only on,2 for time stamping only on,3 for both on.My OS is set at 1.

HKMLsystemcurrentcontrolsetservicesVxDMSTCP

"DefaultRcvWindow" without quotes a string value this should already be in the right pane put in the rwin value you want.

HKMLsystemcurrentcontrolsetservicesVxDMSTCP/parameters

"GlobalMaxTCPWindoSize" without quotes add as Dword value in right pane it probably won't already be there.The Windo part of

this tweak is correct there is not a w at the end of window.

set the value the same as the rwin in DefaultRcvWindow.Select Decimal & put in RWIN.

Cablenut puts the setting above in  HKMLsystemcurrentcontrolsetservicesVxDMSTCP but if you check the tweak on the web

it is supposed to be where I suggested.I actually have it both places now & it hasn't caused any problems.

HKMLsystemcurrentcontrolsetservicesMSTCPNdiparams

string value "(Default)"without quotes set at your MTU value

string value named "@" without quotes set at your MTU value

HKMLsystemcurrentcontrolsetservicesclassnet000

"IPMTU" without quotes string value in right pane set at your MTU value

HKMLsystemcurrentcontrolsetservicesclassnet000NdiparamsIPMTU

string value "(Default)"without quotes set at your MTU value

string value named "@" without quotes set at your MTU value

add values to right pane

HKMLsystemcurrentcontrolsetservicesclassnet000NdiparamsIPMTUenum

delete the values for "Large" "medium" & "small" without quotes

Leave tht values for "Automatic" &(default) rename "automatic" your MTU value like "1500" for example

the put in "Automatic" without quotes as the value of the string value

it should look something like this example I could not copy the string value symbol so where I type string value is where the

symbol would be

string value 1500      "Automatic".If you make this last tweak you need to make these setting to network in the control panel

.Select your internet connection( such as Dial-up adapter this is what my OS uses)

then select properties then advanced highlight IP Packet size& select automatic.Then OK&OK again.you need to do this for each

type of connection you have.

HKMLsystemcurrentcontrolsetservicesclassnet000NdiparamsIPMTU002

string value "IPMTU" without quotes set at your MTU value

There may be other values here like 003,004,005 depending on your system network put in like the 002 value

HKMLsystemcurrentcontrolsetservicesclassnet trans000

string value "MaxMSS" without quotes set at your MTU value

string value "MaxMTU"without quotes set at your MTU value

There may be other values here like 002,003,004,005 depending on your system network put in like the 000 value

You can check the values your system has at ths site https://www.speedguide.net/index.php select the TCP/IP Analyzer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...