Jump to content
Sign in to follow this  
DMN

Help with my sucky connection

Recommended Posts

:::.. Download Stats ..:::

Connection is:: 37 Kbps about 0 Mbps (tested with 97 kB)

Download Speed is:: 5 kB/s

Tested From:: https://testmy.net/ (server2)

Test Time:: Sun Jan 15 2006 20:00:00 GMT-0500 (Eastern Standard Time)

Bottom Line:: 1X faster than 56K 1MB download in 204.8 sec

Diagnosis: May need help : running at only 0.77 % of your hosts average (aol.com)

Validation Link:: https://testmy.net/stats/id-5VKHJ4D2L

:::.. Upload Stats ..:::

Connection is:: 25 Kbps about 0 Mbps (tested with 97 kB)

Upload Speed is:: 3 kB/s

Tested From:: https://testmy.net/ (server2)

Test Time:: Sun Jan 15 2006 20:08:44 GMT-0500 (Eastern Standard Time)

Bottom Line:: 0X faster than 56K 1MB upload in 341.33 sec

Diagnosis: May need help : running at only 9.69 % of your hosts average (aol.com)

Validation Link:: https://testmy.net/stats/id-6UBMS153L

I have compuserve i have 1 gig of ram 2.2GHz amd 64 processer if it helps.Would it help if i bought a new phone line? yeah i know alot about computers just not about 56k lol.I already went though all the services ROM said to do.I dident do the system.ini crap but I dont think it would improve my connect strength

Share this post


Link to post
Share on other sites

any that really improve my overall connection ? and downlaods i really dont care about web broswing that much im a gamer lol

DMN ~ Try these setting in CableNut Adjuster

for XP on-line gaming.

DefaultReceiveWindow = 12288

DefaultSendWindow = 8192

DisableAddressSharing = 1

InitialLargeBufferCount = 100

InitialMediumBufferCount = 240

InitialSmallBufferCount = 320

LargeBufferSize = 12288

MaxFastTransmit = 6400

MediumBufferSize = 8192

PriorityBoost = 1

SmallBufferSize = 4096

TransmitWorker = 20

FastSendDatagramThreshold = 1024

EnableFastRouteLookup = 0

EnablePMTUDiscovery = 0

IgnorePushBitOnReceives = 0

GlobalMaxTcpWindowSize = 6432

MaxFreeTcbs = 8000

MaxHashTableSize = 16384

MaxNormLookupMemory = 5000000

SackOpts = 1

SynAttackProtect = 0

Tcp1323Opts = 0

TcpLogLevel = 1

MaxDupAcks = 2

TcpMaxHalfOpen = 100

TcpMaxHalfOpenRetried = 80

TcpRecvSegmentSize = 536

TcpSendSegmentSize = 536

TcpTimedWaitDelay = 30

TcpUseRFC1122UrgentPointer = 0

TcpWindowSize = 6432

MaxConnectionsPer1_0Server = 20 or 8

MaxConnectionsPerServer = 20 or 4

DefaultTTL = 64

DisableUserTOSSetting = 1

TcpMaxDataRetransmissions = 6 ~ you can raise this if you experience dis-connections

DefaultTOSValue = 96

The other thing you need to do for on-line gaming w/dial-up is turn off both hardware and software compression;

right click your connection icon in your system tray and click status (or goto Network Connections), > Properties under General tab > Connect using ~ click Configure and uncheck Enable modem compression.

Now goto Networking tab > Type of dial-up server I am calling > Settings and uncheck Enable software compression.

now goto Control Panel > Phone and Modem Options > Modems > Advanced tab > click Change Default Settings and in Data Connection Preferences > choose Disabled for Compression.

. . .after many tweaking nights ~ these are the best settings I have found for on-line gaming w/dial-up.

Share this post


Link to post
Share on other sites

hey ROM any thign that will give me a overall stronger connection?because 39 kb is pretty bad.Another thing ive been trying to turn off compression on the networked places thing for a while now and it will not open (preferances) is anything short of re adding my internet in there i can do to open it.Also what do you think about this page I saw it in one of your old posts http://www.webnovice.com/dec00/modemoverclock.htm

does the one reg edit he did improve the profromance alot ?

P.S  could check out internet tweak 4.5 on magellass.com(its a dialup modifier program) could you guys tell me if it helps alot i really dont know what options to select lol thanks again

Share this post


Link to post
Share on other sites

Hey DMN.First ROM has an exceptional connection

I think he would be the first to admit that.Most of us with dial-up do not.Yours may be already as good

as you are going to get it but trying the tweaks can make your connection perform better in

a lot of cases.The testmy test shows you have AOL a lot of people complain about AOL I

haven't had an AOL connection so I don't know but in general if you can get an ISP thats not

AOL it will probably be better.

ROM suggests disabling compression but when he does this it forces MSMPPC compression.

My ISP doesn't support this so when I disabled all compression I experienced a real slow down

It may be the same for you.

I will see if I can find you something on getting the network places to work.

There are several regedits in the link so which one do you have a question about?

Try the tcpip analyzer at the site below & post the results.

https://www.speedguide.net/

Also you line or loop distance is a major factor on dial-up speed.Thee best way to find

legnth is to call your telephone company but the CO distance here is a good estimate to start with.

post your distance after checking.

http://www.dslreports.com/prequal/distance

Share this post


Link to post
Share on other sites

TCP properties for IP = 172.165.101.181 ()

Browser/OS = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Notes: Read the Analyzer FAQ if the above is not your IP address.

TCP options string = 0204055001010402

MTU = 1400

MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.

MSS = 1360

MSS is not optimized for broadband. Consider increasing your MTU value.

Default Receive Window (RWIN) = 6800

RWIN Scaling (RFC1323) = 0 bits

Unscaled Receive Window = 6800

RWIN is a multiple of MSS

Other values for RWIN that might work well with your current MTU/MSS:

522240 (MSS x 48 * scale factor of 8)

261120 (MSS x 48 * scale factor of 4)

130560 (MSS x 48 * scale factor of 2)

65280 (MSS x 48)

bandwidth * delay product (Note this is not a speed test):

Your RcvWindow limits you to: 272 Kbps (34 KBytes/s) @ 200ms

Your RcvWindow limits you to: 108.8 Kbps (13.6 KBytes/s) @ 500ms

Consider increasing your RWIN value to optimize TCP/IP for broadband.

MTU Discovery (RFC1191) = OFF

Time to live left = 55 hops

TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349) = 00000000 (0)

For the second one I got no est.

and again how much would the reg edit on this artical help http://www.webnovice.com/dec00/modemoverclock.htm

and its really not AOL its like a partner company called compuserve but have any suggestions on a  differnet isp, I like compuserve because I've hardly ever had any disconnects in 5 years

Share this post


Link to post
Share on other sites

DMN some of the information in this MS article may help trobleshoot & fix your network places.

http://support.microsoft.com/kb/825826/en-us

I think the regedit settings in this link are not for XP but 98 &ME.

http://www.webnovice.com/dec00/modemoverclock.htm

The only way to find your line or loop distance then will be to call your telephone company.You need to talk to a tech.

I will do some checking into compuserve but the few disconnects sounds good.

Your ISP is probably setting the MTU at 1400 but it could be something else maybe ROM could help with this.I think he had to get his to work at 576 for gaming.

Have you installed cablenut?The settings below in cablenut may help this.It makes the settings in the registry for you.

TcpWindowSize = 6432

GlobalMaxTcpWindowSize = 6432

TcpRecvSegmentSize = 536

TcpSendSegmentSize = 536

EnablePMTUDiscovery = 0

Share this post


Link to post
Share on other sites

DMN; The shortest phone cable from the PC to the wall is best .But you need to have it usable

not many will use a cable so short they have to set the PC on the floor by the wall jack  :haha:

On this setting if you don't like the way it performs change back to 1.EnablePMTUDiscovery = 0

On the phone cable if you can make your own with twisted pair CAT3 or Cat5 they are the best quality.You probably already do this but your modem internal or external should be the only thing plugged into the wall jack.& no phone plugged into the modem .Most have a place for this but it lowers performance.

Share this post


Link to post
Share on other sites

anything I can do to change my MTU? what should it be  also check out the internet tweak program from magellass.com I dunno if it helsp byt theres 3 pages of options I don't under stand xD could you check it out for me please

thanks again

Share this post


Link to post
Share on other sites

DMN:Unless the changes in cablenut change the MTU then I don't know maybe ROM can help you with this when hes here.

I'm not much of a fan of tweak programs they mostly make system changes for you you can make yourself & may make some changes you don't want. But I will give it a look.

Share this post


Link to post
Share on other sites

DMN;Maybe this will help with changing the MTU I didn't ask but I assumed you have XP. .I didn't find 3 pages of options for Internet Tweak at the link or anything about xD.

A lot of the information below is for PPPoE but I think some of it can be applied to Dial-up so XP will use  MTU of 576 & MSS of 536 for dial-up.When this is what is wanted.

I find some conflicts of information on this .So I guess you need to try it both ways

if you are having problems setting the MTU.

EnablePMTUDiscovery

When set to 1 (True), TCP attempts to discover MTU automatically over the path to a remote host. Setting this parameter to

0 causes MTU to default to 576 which reduces overall performance over high speed connections.

OR

Setting MTU overrides the default MTU for the network interface it is added to. Note that if

EnablePMTUDiscovery is set to 1, TCP will use the smaller value of this local MTU and the

"Discovered" MTU of the underlying network connection. If you'd rather use only the MTU value

specified here, you'd have to disable PMTUDiscovery, which would prevent your system from

detecting the network MTU.

The above information seems to conflict.

HKLMSYSTEMCurrentControlSetServicesTcpipParameters

EnablePMTUDiscovery="1" (DWORD - boolean, valid settings are 0-->False and 1-->True. Many connections perform better with

this entry at 1, however, if you prefer to set your upstream to send fixed 1500 packets, you might want to use 0 instead).

When set at 1, establishing connections and initial transfer speed might slow down a bit, however you will get better

throughput if somewhere in the path large packets need to be fragmented.

To modify the PPPoE MTU size, create the following registry key:

HKEY_LOCAL_MACHINESystemCurrentControlSetServicesNdiswanParametersProtocols0

Then add the following registry entries.Entry name Data type Value data

ProtocolType REG_DWORD 0x00000800

PPPProtocolType REG_DWORD 0x00000021

ProtocolMTU REG_DWORD the appropriate MTU size (in decimal)

To do this: 1. Click Start, click Run, type regedit, and then click OK.

2. Locate and then click the following key in the registry:

HKEY_LOCAL_MACHINESystemCurrentControlSetServicesNdiswanParameters

3. On the Edit menu, point to New, and then click Key.

4. Type Protocols, and then press ENTER.

5. On the Edit menu, point to New, and then click Key.

6. Type 0, and then press ENTER.

7. On the Edit menu, point to New, and then click DWORD Value.

8. Type ProtocolType, and then press ENTER.

9. On the Edit menu, click Modify.

10. Type 800, and then click OK.

11. On the Edit menu, point to New, and then click DWORD Value.

12. Type PPPProtocolType, and then press ENTER.

13. On the Edit menu, click Modify.

14. Type 21, and then click OK.

15. On the Edit menu, point to New, and then click DWORD Value.

16. Type ProtocolMTU, and then press ENTER.

17. On the Edit menu, click Modify.

18. Type the appropriate MTU size (decimal value), and then click OK.

19. Quit Registry Editor.

Notes

Share this post


Link to post
Share on other sites

DMN ~ did you find the distance to your telco?

that will be the bigest factor in your connect speed.

AOL might be a big factor, too. . . .can you change ISP's?

were you able to stop compression?

I have a partitioned drive just for on-line gaming and the settings I gave you are the ones I use on that drives connection.

with on-line gaming alot of lagging problems have to do with the game video settings more than your connect speed. . .lowering your in-game vid resolutions to 800 x 600 and lowering the visual texuring and effects might help.

also, games have a game.cfg file that you can edit. . .look for a MaxPacketRecieve line and lower it(most send at 1300, try 800), if you can.  you'll also find most, if not all, your game settings in that file.[it's not cheating to change settings in that file, either, it's just your preferences]

also, I helps playing on-line at off peak hours ~ lol

Oh, by the way ~ are you running win XP?  . . .wasn't sure.

Share this post


Link to post
Share on other sites

Just out of off topic curiosity what on line games do you play ROM

. . .mostly Joint Operations (NovaLogic) and somtimes Dawn of War.

what do you play?

. . .and what was the "Yes I am" in reference too?

Share this post


Link to post
Share on other sites

yes is to XP question

I play:half life 2, CS:S sometimes , Garys mod, Continuum , WoW private servers, Battlefield 1942, Call of duty 2 is what i would like to play its for isdn so dial up could play it , if I improve more i can quit the single player and play online lol

Share this post


Link to post
Share on other sites

DMN ~ I just changed my settings, again ~ lol

. . .but I stayed connected during peak hours

new cablenut settings; [online gaming]

DefaultReceiveWindow = 8192

DefaultSendWindow = 4096

DisableAddressSharing = 1

InitialLargeBufferCount = 1

InitialMediumBufferCount = 24

InitialSmallBufferCount = 32

LargeBufferSize = 4096

MaxFastTransmit = 640

MediumBufferSize = 1504

PriorityBoost = 0

SmallBufferSize = 128

TransmitWorker = 32

FastSendDatagramThreshold = 1024

EnableFastRouteLookup = 1

EnablePMTUDiscovery = 1

IgnorePushBitOnReceives = 0

GlobalMaxTcpWindowSize = 8760

MaxFreeTcbs = 8000

MaxHashTableSize = 16384

MaxNormLookupMemory = 5000000

SackOpts = 1

SynAttackProtect = 1

Tcp1323Opts = 0

TcpLogLevel = 1

MaxDupAcks = 2

TcpMaxHalfOpen = 100

TcpMaxHalfOpenRetried = 80

TcpRecvSegmentSize = 1460

TcpSendSegmentSize = 1460

TcpTimedWaitDelay = 30

TcpUseRFC1122UrgentPointer = 0

TcpWindowSize = 8760

MaxConnectionsPer1_0Server = 8

MaxConnectionsPerServer = 4

DefaultTTL = 128

DisableUserTOSSetting = 0

TcpMaxDataRetransmissions = 6 

DefaultTOSValue = 96

In my game.cfg file I set my

mpmaxpacketsize = "800"

Share this post


Link to post
Share on other sites

DMN, If you have not already done so try out all the access numbers that are local to you some are routed differently and may offer a better/ higher connection. Try using other isp access numbers as well.

Even if you do connect at higher speeds keep in mind you may recieve alot of modem errors. When it comes to dial up alot of times Slow is fast, Fast is slow.

Like cholla said if you can, make your own cat5 twisted pair line run it directly from the wall into the comp. That's how I do mine you can find the items you need at radio shack fairly inexpensive.

Do you have a satellite? If so make sure your satt. box is not plugged into another jack in the house

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...