Jump to content

Can't get ANY speedtest to run. Error produced.


Recommended Posts

Hi, all!

For the past few months I've not been able to run a speed test on testmy.net. I've used your speedtest successfully for the past several years though until recently. Now, when I click on any speedtest, I get the following error message:

Our tests can only be initiated from testmy.net's server. Choose a link below if you would like to test your connection.

Chose a popular destination

Dual Test - a tool for testing your internet connections upload and download speed.

Download Test - a tool to test your internet connections download speed.

Upload Test - a tool to test your internet connections upload speed.

Automatic Test - a tool to test both upload and download speed on a set schedule, great for graphing your connection over a period of time.

Test Mirrors - a list of test mirrors from all over the world.

When I click on any of the above links, the test option page loads but upon choosing ANY test option, it produces the above error result rather than running the test. The same error repeats each time I try. I've tried a few of the obvious fixes like clearing browser cache and configured both Norton Antivirus and ZoneAlarm to allow all cookies from testmy.net but still can't actually run a test now, when before I was able to run them all. The only change I've made to my computer recently has been Windows Update around the same time I noticed not being able to get speedtest to run but can't see how this would cause the error. I'm running Windows XP Pro, SP3, Internet Explorer 7. I can get other speed tests like speakeasy to run O.K. but I really miss being able to use testmy.net speedtest so I hope you can advise me on solving the problem.



Update: Just after I posted the above query, I decided to attempt a speedtest while being logged in and IT WORKED! I never had to log in in the past to run the test. Is it now necessary to be logged in to use speedtest? If so, since when?

Link to post
Share on other sites

You must have had a link to a test that has been , for security reasons, removed. All the tests are still the same, but some links to them have been removed

Anyone can take any test here at testmy.net, but as the message says , the tests must originate from the server itself. Which should have been this way all along.

I logged off, and tested, and have had no issues, I'm certain it was caching of a now no longer available link, please clear your browsers cache to avoid this.

Link to post
Share on other sites

Hi and thanks so much for your quick reply.

I've tried all the obvious things as stated earlier, including clearing IE7 browser cache MANUALLY. I also have it set to clear cache automatically upon shutdown too. I still get the same error.

Originally, I WAS using a link button I created to the test page and after the problem began, I even tried closing out the browser, re-opening it, then manually typing www.testmy.net directly into the address window and navigating to the test option page via the site's menu.

The SAME error message is produced even without using a link and with a purged browser cache. Somehow, logging in allows the test to run without a hitch. I'm still stumped.

Again, the only thing that has changed on my computer is a Windows Update around the same time I noticed the problem, (2 or 3 months), but I can't actually pin the problem down to that update either.

Any other thoughts?

Once again, THANKS!

Link to post
Share on other sites

Update: I just successfully ran the speedtest again WHILE BEING LOGGED IN with NO problem. I tried it just BEFORE LOGGING IN and got the same error message again. I also just now opened a SECOND instance of the browser, typed in www.testmy.net, navigate to the test option page via the menu, chose a test, and get the SAME error message at this very moment, as I write this update. As I write, I have TWO instances of IE7 open. ONE, I'm logged into and CAN run the speedtest, and the OTHER, I'm NOT logged into, produces the error message.

Link to post
Share on other sites

Does whoever your ISP is, do any funny business on it's lines?  Or has some Internet Explorer security setting changed via Windows update? I see my IE version 6 has checked "enable third party browser extensions" that I had unchecked.

Very odd.  :undecided:

EDIT: Would you still get the same problem if you used FireFox?


Link to post
Share on other sites

ON that account there are several better browsers than firefox. Several to choose from.  [nerdly]


Haven't checked for a long time on the alternate browsers that use Internet Explorer as their 'Engine', but some are vulnerable as IE, as they are just a skin on top of Internet Explorer and therefor subject to the same security risks as if you were(which you are) using Internet Explorer.

But I think at the moment, Adobe's PDF reader is the most exploited thing on the Web at the moment. So many holes and so easy to exploit, since it's comes with many Manufacturers OEM version of Windows.

Link to post
Share on other sites

Thanks for all your replies. Yes, I've used other browsers like FireFox and Mozilla before but they have had their own problems too, like not being accepted or working properly at certain websites such as banking and Windows Update as well as others. I'm in no way a loyalist to ANY particular browser, as they all have had their problems, it's just that Internet Explorer is SUPPOSED to work at more sites than any other browser. I've looked at all my browser settings and all seem to be correctly configured. However, I, like many others out there, am beginning to believe that Internet Explorer just might be haunted! It seems to have a mind of it's own sometimes.

As for "funny business on the lines", that's a very valid point. I've been with Verizon DSL for several years now and when it's working, it's fine but since they've been pushing Fios, they've all but abandoned their copper DSL customers as far as maintenance and customer service is concerned. When their geeks are working on the system at the central office, or on the wires in the field,  my service is spotty at best and their customer service reps have no clue that their own technicians are even working on the system. Many times this has led to customer service run-arounds and wild goose-chases that have literally cost me DAYS on the telephone and repeated checking and re-checking of my own equipment over and over again. During the past Christmas holidays, BOTH my phone AND internet were useless for 10 DAYS due to severe hum and static on the line. 10 days to dispatch a tech to fix their own wires! Then, they want to sell me Fios. I ask them "if Verizon can't keep something as simple as copper wire up and running, how the hell can I expect Verizon to keep something as sophisticated as fiber optics working properly? They can't service their existing long-time customers but they're pushing the "new" Fios in the hope of getting "fresh meat" for their fiber marketing efforts. So, as for "funny business on the lines", there's no doubt there's some of that going on but it's very hard to prove. I WAS going to switch to Fios when it became available last year but NOW, I think I'd rather use two tin cans and a string!

Anyhow, until I can get this speedtest issue figured out, I guess I'll just need to log in first before I can use it. So much for a quick and convenient test of line speed.

Link to post
Share on other sites

  • CA3LE locked this topic
This topic is now closed to further replies.

  • Create New...