Jump to content
Sign in to follow this  
Guest Pacers Fan

Firefox Extensions Problem

Recommended Posts

Guest Pacers Fan

Everytime I attempt to get an extension for Firefox, I get an message that says, "Software Installation is currently disabled. Click Edit Options... to enable it and try again". I don't see anywhere I can enable this in the options.

Share this post


Link to post
Share on other sites
Guest Pacers Fan

You need to add addons.mozilla.org to the allowed sites list.

Go Tools > Options > Content....

Look at picture below:

Did that. It still doesn't work. All the settings on mine under contents look exactly like yours.

Share this post


Link to post
Share on other sites

Did that. It still doesn't work. All the settings on mine under contents look exactly like yours.

That's odd.

Try including the wildcard * after it.

Like this:    addons.mozilla.org*

Then close all Firefox windows then reopen and try loading an extension again..

Share this post


Link to post
Share on other sites
Guest Pacers Fan

That's odd.

Try including the wildcard * after it.

Like this:    addons.mozilla.org*

Then close all Firefox windows then reopen and try loading an extension again..

Tried that, and it still doesn't work.

Share this post


Link to post
Share on other sites

your profile for firefox should be in documents and settings/username/application data if u dont find that folder go to program files/mozilla firefox/defaults/profile and delete all files in the profile folder, upon starting firefox again you should be able to create a new profile. Note: this worked for me in the same problem i had bout a month ago. Cant assure it will work for you, anyway deleting your firefox profile wont render your computer useless so its pretty safe

Share this post


Link to post
Share on other sites
Guest Pacers Fan

your profile for firefox should be in documents and settings/username/application data if u dont find that folder

My Documents? No settings file there.

go to program files/mozilla firefox/defaults/profile and delete all files in the profile folder, upon starting firefox again you should be able to create a new profile. Note: this worked for me in the same problem i had bout a month ago. Cant assure it will work for you, anyway deleting your firefox profile wont render your computer useless so its pretty safe

I deleted everything in the folder and re-started my computer, but my favorites are still there, and I wasn't asked to create a new profile.

Share this post


Link to post
Share on other sites
Guest Pacers Fan

Go here - http://www.mozilla.org/support/firefox/edit#profile

Should look something like

C:WINDOWSApplication DataMozillaFirefoxProfilesxxxxxxxx.default

Now whenever I try to open Firefox, I get this message:

Firefox is already running, but not responding. To open a new window, you must first close the existing Firefox process, or re-start your system.

Should I uninstall/install?

Share this post


Link to post
Share on other sites

Pacers Fan,  Right click on the time in the bottom right corner choose Task Manager do you see Firefox running in Applications? If so choose end task.

What version are you using? Might just be better off uninstalling it and downloading the newest ver.1.5.0.1

If you uninstall Firefox run a good reg cleaner and remove any traces of it before re-installation

Share this post


Link to post
Share on other sites
Guest Pacers Fan

Pacers Fan,  Right click on the time in the bottom right corner choose Task Manager do you see Firefox running in Applications? If so choose end task.

I wish I had the XP task manager. All I have is the crappy task manager that comes with ME. Firefox wasn't running.

What version are you using? Might just be better off uninstalling it and downloading the newest ver.1.5.0.1

I recently downloaded the newest version, but had this problem before I did. I'll uninstall it, anyway.

Share this post


Link to post
Share on other sites

Pacers Fan, Look under tools/options/content the exceptions box at the right should have the name of the sites allowed to install software. The small box to the left is for the warning of the impending installation.

Under tools/options/advanced there are also update settings which you may have to adjust in order for the installation to take place. Read the choices

If that doesn't work try the following:

http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_%28Firefox%29

If you click a web site's "Install" link and you see a message bar that says "Software installation is currently disabled. Click Edit Options... to enable it and try again."

Firefox 1.5: If you previously disabled this option and then updated to Firefox 1.5, the disabled setting will be carried over. Since the option to enable software installation no longer exists in the UI, you will need to use about:config to reset the "xpinstall.enabled" preference to the default "true" value (bug 310737). Here's step by step how to do this: Type about:config to Location Bar and hit enter. Type xpi to filter and find xpinstall.enabled. Make sure it's value is true. (double click will toggle). Now you should be able to install.

Remember to close Firefox once your done, for the changes to take effect.  :arrow:

Share this post


Link to post
Share on other sites
Guest Pacers Fan

Pacers Fan, Look under tools/options/content the exceptions box at the right should have the name of the sites allowed to install software. The small box to the left is for the warning of the impending installation.

Under tools/options/advanced there are also update settings which you may have to adjust in order for the installation to take place. Read the choices

If that doesn't work try the following:

http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_%28Firefox%29

If you click a web site's "Install" link and you see a message bar that says "Software installation is currently disabled. Click Edit Options... to enable it and try again."

Firefox 1.5: If you previously disabled this option and then updated to Firefox 1.5, the disabled setting will be carried over. Since the option to enable software installation no longer exists in the UI, you will need to use about:config to reset the "xpinstall.enabled" preference to the default "true" value (bug 310737). Here's step by step how to do this: Type about:config to Location Bar and hit enter. Type xpi to filter and find xpinstall.enabled. Make sure it's value is true. (double click will toggle). Now you should be able to install.

Remember to close Firefox once your done, for the changes to take effect.  :arrow:

Thanks, but right now I can't even open Firefox.

Share this post


Link to post
Share on other sites
Guest Pacers Fan

http://www.evilsoft.org/?p=69

read that.. 1.5.0.1 kills more extensions..

here is another work around.. http://www.downloadsquad.com/2006/02/03/how-to-make-old-extensions-work-in-a-new-version-of-firefox/

Sorry.  i would have posted this earlier had i seen it..

That actually wasn't my problem. I had no extensions to begin with, and all I needed help with was downloading them. Since then, though, I must have edited something that did not allow Firefox to run properly, and even after uninstalling/registry editing/re-installing, I can't get it to open.

Share this post


Link to post
Share on other sites
Guest Pacers Fan

Found the problem:

After uninstalling, the Firefox application data folder still remained. So, I uninstalled again, removed the Firefox application data folder, and re-installed. Now I can open it, and even get extensions!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...