Jump to content
scdreamin3

Just a quick question on partitioning my hard drive

Recommended Posts

  I just had a question, and it is really not concerning speed or tweaking ip settings, so I decided to post it in here, since it is kind of off topic.

  I know there are a few among us that run linux or ubuntu, or some other distro of such. If you have been following my posts you see that I have had quite a fun time this past week, NOT. lol. Well I have finally got windows and ubuntu working together harmoniously on my WD 160gb hard drive. when I want to boot into windows, i boot at startup, same for ubuntu. I have finally got internet working on ubuntu, and all is well in the land of double os's.  :cheesy:

  Just one minor problem though. When I installed Ubuntu, it left around 7gb of the drive reserved for Windows XP. The rest, around 150gb or so, it took for itself. Well now when I try to download something or install into Windows, it says I do not have enough disk space. I am pretty new to ubuntu/linux, and am just a noob, really. So is there any way to repartion the drive so that Windows could have 70 or so gb and ubuntu 70? I tried by using the ubuntu cd to change the sizes manually, but it doesn't work. I have read all I could in forum after forum, and to be quite honest, it was just like as , i think it was ninjageek said, most of the people on linux forums don't really explain things in a way that a noob such as myself would understand.

  So with all that being said, does anyone know how to repartition the drive to make windows xp have a bigger partition after an install of ubuntu?

  Thanks for any help.

Share this post


Link to post
Share on other sites

  Just a follow up. I booted from the live cd of ubuntu and started gparted. I went through the process of shrinking the Ubuntu partition, down to roughly 20gigs, in the hopes that I could increase the Windows partition. Well unfortunately, the 20 gigs of Ubuntu was all the way left. so I then had to move that partition all the way right, leaving about 120 gigs of free space between Ubuntu and Windows. Well, wouldn't you know it, there is no way to expand the windows to the right into that free space.

  So anyway, what I ended up doing was just install a new ubuntu partition and did a guided, then changing to my windows partition having a little under half of the hdd, and ubuntu having a little under half.  :idiot2: I should have done that in the first place.

  Well, I now have everything set up right and I am leaving it that way, not going to touch it again. Or, at least until October when they come out with an Ubuntu update.  :grin:

  Thanks for the help Mudmanc4.

Share this post


Link to post
Share on other sites

i tell you what, partitioning used to be, much more difficult, and it really still is, but thanks to the geniuses that have stoked on this for so long, we can stand on there shoulders.

When i get into it, it becomes addicting, there are so many different ways to partition between linux, that you can really do some interesting things. Most of the procedures, and ways of doing this are rarely used. You should get a bit more into it in your spare time, it really is the heart of the hard drive configuration.  Just for fun.

Share this post


Link to post
Share on other sites

What I did to partition my notebook harddrive  [ 250 GB ] to dual boot Vista and Kubuntu was

Install Vista completely on a 132.97 GB partition with a another 12.95 GB partition going to the HP Recovery. 

That left 86.96 GB of free space. I then put in the install disk for Kubuntu, when it got to the partition part of the install, all I had to do was click on the option that said[ install in the largest free space ] and then let Kubuntu finish doing the install.

After Kubuntu install was done, I  check Windows Disk Management and ended up with 4 partitions. #1 was Vista with 132.97 GB,#2 was Kubuntu with 83.38 GB, #3 was also Kubuntu with 3.58 GB, the #4 was HP Recovery with 12.95 GB

Share this post


Link to post
Share on other sites

  Kewl Buntz. that'll work. Wow, all this time I thought  I was the only one trying this Ubuntu or linux thing, at least in this forum anyway. I am glad to know there are people here to turn to when I have questions. Thanks Mudmanc4 and Buntz.

  Ha ha, now to put that to use........lol. I probably am dumb for asking it, and when I get the problem resolved I am going to be duh! It was right there in front of my face this whole time. The question is concerning bluetooth. I connect to the internet currently through using "wvdial" in Ubuntu. I use my phone as a modem.  I have installed the kde bluetooth, tried to set it all up, read several topics in several forums, etc. The thing just does not work. In Windows, all I have to do is set my phone to bluetooth and click on the bluetooth icon on the taskbar, connect to the internet and I am done. In Ubuntu the only thing that is available for bluetooth, or at least in my setup, is file transfer. Modem isn't even a choice. I have tried downloading and installing a package from Bluesoleil, but it says it is dependent on asus something or another.

  I mean, I am happy to finally have internet set up on Ubuntu. But, just like in windows, when the battery goes dead on my phone, I have to unplug the usb cable and plug in my charger. Unfortunately my alltel hue does not charge through the usb cable. So I contained the problem in windows by using bluetooth to connect while my phone is charging. I would love to do the same with Ubuntu, but I just can't figure it out.  :undecided:

Share this post


Link to post
Share on other sites

Good luck with getting bluetooth to work on linux. I have never been able to get it to work. I needed it for a keyboard and mouse and it just would work, as most wireless services on linux.

You can give this a try if you haven't already http://divby0.blogspot.com/2008/01/howto-bluetooth-for-linux.html

Share this post


Link to post
Share on other sites

 Yeppers. I think you are right dlewis. I am about to give up on the bluetooth dongle in Ubuntu. I haven't quit just yet though. There are so many factors involved. You install this when you should have installed that. If you change this it messes with the settings of that. Its mind boggling to say the least. I have "sudo gedit" as a very new part of my vocabulary lately.  :2funny:

 Here is where I am so far. I set up my rfconn file because I will need it later in this post. Here is part of that guide......

http://img702.mytextgraphics.com/photolava/2008/08/17/blue11-fjz99jc1.png

 And my resulting file.........

http://img108.mytextgraphics.com/photolava/2008/08/17/blue10-4bjslk6sb.png

 Oh, and by the way, sorry that I am posting links instead of code. I haven't quite figured out how to install the flash player for opera in Ubuntu. My firefox is down for some reason. It says that I am in offline mode, when i am good and well connected to the internet! That will be yet another issue I have to resolve.  :grin2:

So anyway, then I followed this guide to set up wvdial, so that I can call out with my modem/phone...

http://img801.mytextgraphics.com/photolava/2008/08/17/blue1-fjz8ewb4.png

http://img108.mytextgraphics.com/photolava/2008/08/17/blue2-4bjscooak.png

http://img702.mytextgraphics.com/photolava/2008/08/17/blue3-4bjsdgtus.png

http://img902.mytextgraphics.com/photolava/2008/08/17/blue4-4bjsdsnoi.png

And here is how my wvdial.conf file looks..........

http://img107.mytextgraphics.com/photolava/2008/08/17/blue8-4bjsqwh00.png

http://img802.mytextgraphics.com/photolava/2008/08/17/blue9-4bjsrtq7w.png

And this is when I dial out with usb cable attached.........

http://img902.mytextgraphics.com/photolava/2008/08/17/blue30-4bjt0i574.png

 Good connection, no problem.

And now when I try to connect via bluetooth.........

http://img108.mytextgraphics.com/photolava/2008/08/17/blue31-4bjt3eu35.png

Bad Initialization string? What tha hank? Its the same init string that i use to connect via usb! Am I missing something here? Anyways. That is where I am at. I have tried and tried to find the APN setup for Alltel, but with no luck, so I figure it is the same as for connecting via usb.

I think I am going to give it a rest for a couple of weeks and just be glad that I at least do have internet in Ubuntu through usb connection, and resolve some of my other Ubuntu issues.

Share this post


Link to post
Share on other sites

Well ladies and gentleman. I did it!!!  I am now connected to the internet on UBUNTU via bluetooth modem. They said it couldn't be done. But I did it! Yay! The speeds really suck, I am sure I will find a way to resolve that though.

Seeing as how in Ubuntu I have been getting speeds of 700-1000 via usb cable, compared to windows speeds of 250-400. And yes, it was just as I said, it was right in front of my face the whole time. And simpler really, than what I had been trying to do.

  Here is a rundown of how I did it - - -

  This is from a few different guides so I will condense into one - - -

Listing Bluetooth device

    * Make your phone Bluetooth discoverable.

    * Run the following at a shell prompt:

hcitool scan

    * Copy the MAC address (the text with the capital letters, numbers, and ':'s) somewhere convenient. You'll need it many times.

Pairing

You can skip this section if you've already paired your phone with your computer. However, consider the final optional step, as your phone might otherwise nag you every time you use if for dialup.

    * Run the following, replacing your-phone-mac-address with the proper data

sudo hcitool cc your-phone-mac-address

    * Run the following, replacing your-phone-mac-address with the proper data

sudo hcitool auth your-phone-mac-address

    * Find the channel number for your phone's dialup service by running the following.

sdptool search DUN

    * Alternatively, get information about all the services on your phone by running this, replacing your-phone-mac-address with the proper data

sdptool browse your-phone-mac-address

    * In either case, look under "Service Name: Dial-up Networking"

    * Under "Protocol Descriptor List:" and "RFCOMM", there should be a number after "Channel:"

    * Remember that number; you'll need it for the rfcomm configuration

    * Run

gksudo gedit /etc/bluetooth/rfcomm.conf

    * Paste the following into the file, replacing your-phone-mac-address and your-phone-rfcomm-channel with appropriate values

rfcomm0 {

        bind yes;

        device your-phone-mac-address;

        channel your-phone-rfcomm-channel;

        comment "Bluetooth PPP Connection";

}

Heres how mine looks --

<a href="http://www.photolava.com/view/itc9.html"><img src="http://img107.mytextgraphics.com/photolava/2008/08/23/rfcom-4bm8xyywp.png" alt="Free Photo Hosting - Photolava.com" /></a><br /><br />

      Save and close the rfcomm.conf file

Note: On the Nokia N95 (and possibly other Symbian S60 phones) the RFCOMM channel number is not consistent, but seems to change from time to time. If you have a phone that behaves like this, and you find youself unable to connect, you will need to re-run sdptool as described above to see if the channel number has changed. Rather than edit rfcomm.conf (and hence have RFCOMM bind to the channel at startup) you may find it more convenient to bind the RFCOMM channel on the command line:

rfcomm bind 0 your-phone-mac-address your-phone-rfcomm-channel

    * Run the following, which will create the rfcomm0 device

sudo /etc/init.d/bluetooth restart

If you get the wrong channel (or if the wrong channel was bound at startup as a result of rfcomm.conf) then you need to release it before you can bind it again:

rfcomm release 0

Configuring PPP

    * Run the following

gksudo gedit /etc/ppp/peers/BluetoothDialup

    * Paste the following into the file (the file should start out blank)(I found that on my Motorola V360 that I had to comment out #lcp-echo-failure 0 useing T-Mobile.)

debug

noauth

connect "/usr/sbin/chat -v -f /etc/chatscripts/BluetoothDialup"

usepeerdns

/dev/rfcomm0 115200

defaultroute

crtscts

lcp-echo-failure 0

  Save and close the BluetoothDialup file

    * Run the following

gksudo gedit /etc/chatscripts/BluetoothDialup

    * Paste the following into the file (the file should start out blank), replacing your-apn-here with the APN from your data services profile and your-data-profile-number-here with the number you stored the profile into on the phone (probably 2).

TIMEOUT 35

ECHO    ON

ABORT  'nBUSYr'

ABORT  'nERRORr'

ABORT  'nNO ANSWERr'

ABORT  'nNO CARRIERr'

ABORT  'nNO DIALTONEr'

ABORT  'nRINGINGrnrnRINGINGr'

''      rAT

OK      'AT+CGDCONT=2,"IP","your-apn-here"'

OK      ATD*99***your-data-profile-number-here#

CONNECT ""

  **Note. Not all systems have apn's. If you can't find your apn on this page (  http://www.taniwha.org.uk/gprs.html)or here (http://www.quickim.com/support/gprs-settings.html#USA) Call your cellular provider to determine what your apn is.

Now the thing that made it really work. If you don't have Gnome PPP installed, install it from Synaptic Package Manager. This is what really ties it all together. After installed open Gnome PPP. Click on setup and type in the device box  /dev/rfcomm0 and choose Analog modem. Leave the rest alone and close the box.

<a href="http://www.photolava.com/view/itco.html"><img src="http://img902.mytextgraphics.com/photolava/2008/08/23/gnome1-4bm95bwb2.png" alt="Free Photo Hosting - Photolava.com" /></a><br /><br />

Then in the main box type in your username and password. Note -- I have alltel, so username is my phone number followed by alltel.net. password is alltel. Then enter in the phone number box, used to dial into your network, *99***2#.

<a href="http://www.photolava.com/view/itcw.html"><img src="http://img108.mytextgraphics.com/photolava/2008/08/23/gnome2-4bm97pt1q.png" alt="Free Photo Hosting - Photolava.com" /></a><br /><br />

  Now you are almost ready to go. Remember I talked about binding your phone? This is important, and one of the things I was missing. Unfortunately, every time I restart my computer or disconnect my phone, I have to retype this. I haven't found a solution for it, but I am working on a workaround.  If your phone is not bound do it now by opening a terminal and typing

  rfcomm bind 0 your-phone-mac-address your-phone-rfcomm-channel

Now once that is complete, press the connect button on Gnome PPP, and your phone should be connected via bluetooth in Ubuntu!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...