Jump to content
Sign in to follow this  
ninjageek

Toshiba And Hdmi No Sound

Recommended Posts

TOSHIBA Model A505-S6998 Satellite with windows 7 Pro 64 bit. Trying to hook this up to the t.v. through HDMI. I get the picture just fine, But No sound. Shows No option for HDMI going to Control Panel, Then Sounds. It has GOT to be a driver issue, Or something simple. Hope you guys can help.

I did install the drivers from toshiba web site for the sound. No Luck.

Share this post


Link to post
Share on other sites

I'm pretty sure I know what's going on. It being a 64 bit windows machine I doubt it's a driver issue.

You need to go into your sound settings in the control panel and set the audio output device associated with the HDMI to default. This is most likely not set to default. Just look for audio devices in the control panel (or something along those lines), once opened you'll see all the audio devices on your computer. Click the one the one you want the audio to output to and apply the changes. I personally think that windows should do this for you but in many cases it doesn't... I mean, you just plugged it in, I think the computer would be safe in assuming that you want to use HDMI audio out if you just plugged it in. But oh well, it's little things like that why I no longer use Windows myself.

I'm not on a windows machine right now otherwise I'd give you more details. Let me know if this fixes the problem. If you have a hard time with the limited instructions I've given you let me know and when I get a minute I'll post some more details.

So basically, it just needs you go guide it into doing the right thing... it's like 99% there, you just have to tell it to play by default to HDMI.... I've found that once this is set once Windows 7 should remember and automatically do this for you when you plug HDMI in. ... but it's Windows so don't hold me to that ;-)

By the way, I'm not at all a Windows or Microsoft hater... Just stating the obvious, Windows can be unpredictable. Windows is a great OS for most people, just wasn't right for me anymore.

-D

Share this post


Link to post
Share on other sites

I'm pretty sure I know what's going on. It being a 64 bit windows machine I doubt it's a driver issue.

You need to go into your sound settings in the control panel and set the audio output device associated with the HDMI to default. This is most likely not set to default. Just look for audio devices in the control panel (or something along those lines), once opened you'll see all the audio devices on your computer. Click the one the one you want the audio to output to and apply the changes. I personally think that windows should do this for you but in many cases it doesn't... I mean, you just plugged it in, I think the computer would be safe in assuming that you want to use HDMI audio out if you just plugged it in. But oh well, it's little things like that why I no longer use Windows myself.

I'm not on a windows machine right now otherwise I'd give you more details. Let me know if this fixes the problem. If you have a hard time with the limited instructions I've given you let me know and when I get a minute I'll post some more details.

So basically, it just needs you go guide it into doing the right thing... it's like 99% there, you just have to tell it to play by default to HDMI.... I've found that once this is set once Windows 7 should remember and automatically do this for you when you plug HDMI in. ... but it's Windows so don't hold me to that ;-)

By the way, I'm not at all a Windows or Microsoft hater... Just stating the obvious, Windows can be unpredictable. Windows is a great OS for most people, just wasn't right for me anymore.

-D

Yea I did try that. Its not showing any of the HDMI and even installed?? There was one other option in the sound section. Clicked on it, set it as defualt. Nothing. No luck. I did download and install latest sound drivers.

Share this post


Link to post
Share on other sites

This is one of those times I wish I could just hop on your computer and see for myself.

Have you gone into the device manager to see if there are any unrecognized hardware. I know you said that you installed the drivers but it's still possible. Another thing you may want to try is a driver roll back to the default drivers that microsoft offers. Let me know if you need a walk through for any of the above.

-D

Share this post


Link to post
Share on other sites

You need to go into your sound settings in the control panel and set the audio output device associated with the HDMI to default. This is most likely not set to default.

Because HDMI carries audio over the same cable as the video its not handled by the traditional audio controls depending on the type of card, its actually handled by the video card and they tend to stick things in odd places. Sometimes the controls wont even show up unless the computer is started with HDMI connected.

A few things for you to try, look for digital devices as applied science said if its there set it and reopen your video player. Or when you plug in the HDMI cable to the TV and Computer and have video working, restart the computer. On some notebooks they will need the factory video driver for sound out of the HDMI port, so if you upgraded them you may have to roll them back.

Share this post


Link to post
Share on other sites

Because HDMI carries audio over the same cable as the video its not handled by the traditional audio controls depending on the type of card, its actually handled by the video card and they tend to stick things in odd places. Sometimes the controls wont even show up unless the computer is started with HDMI connected.

A few things for you to try, look for digital devices as applied science said if its there set it and reopen your video player. Or when you plug in the HDMI cable to the TV and Computer and have video working, restart the computer. On some notebooks they will need the factory video driver for sound out of the HDMI port, so if you upgraded them you may have to roll them back.

Still trying. I did hook it up and reboot the machine. No luck. Right click on the sound button and changed the default. This is funny. Worked fine with vista. Go figure.

Share this post


Link to post
Share on other sites

TOSHIBA Model A505-S6998 Satellite with windows 7 Pro 64 bit. Trying to hook this up to the t.v. through HDMI. I get the picture just fine, But No sound. Shows No option for HDMI going to Control Panel, Then Sounds. It has GOT to be a driver issue, Or something simple. Hope you guys can help.

I did install the drivers from toshiba web site for the sound. No Luck.

Wow I have been have this same issue, same exact laptop! I had no problems when I first bought it but now I as well can get good picture but no sound. If anyone can help, much is appreciated!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...