Jump to content
Gabe1972

No longer detecting my provider?

Recommended Posts

Entering your IP into TestMy.net/iptools and MaxMind demo doesn't resolve to any provider, city, country.

 

Screen Shot 2017-07-18 at 11.50.09 PM.png

 

Keep in mind that doesn't affect your testing at TestMy.net.  Your results just won't be compared like they used to.  In the future I may provide an option to select the provider you want to compare against, so you'll be able to manually resolve in your case.

Share this post


Link to post
Share on other sites

Yep.  Comparison is the exact reason it's nice for it to detect the provider.  I've noticed that it's doing the same thing for a few other Hughesnet users, but with some it's sporadic, as well.  I just don't understand why it started doing this when absolutely nothing has changed, or at least nothing on my end.  

 

Could something have changed on Hughesnet's end that's causing it to do this?  

Share this post


Link to post
Share on other sites
Posted (edited)

That is certainly odd, it's most likely the SQUID Proxy on Hughesnet messing up...  I have the same issue.

I actually just did some testing, this is certainly an issue with the Hughesnet Proxy system that users go through...

If you look at my two most recent tests, the one that the system couldn't detect the ISP was done with Web-Acceleration enabled... The one that did detect the ISP, had it disabled.

Web-Accel On:
dZYoxKNAW.png


Web-Accel Off:
GamKVd0JF.png


CA3LE, can you confirm the IP issue between those two tests somehow?  I suspect the Web-Accel Off one shows a Hughesnet IP, yet the one that has it turned on is showing a multicast address.  Once confirmed I can report my findings to... certain people.

There are also other bugs here with Web-Acceleration on at the Results page... All I get is a graph, nothing else below it like I once did...

Edited by C0RR0SIVE
Added information

Share this post


Link to post
Share on other sites

Same here only i am on att u verse. it detects my ip as 250.120.85.81 which is similar to the 255.255 thing. i have not changed anything on my end either. can anyone tell me if this is a glitch? OS windows 10 pro, google chrome x64. thanks in advance!

Share this post


Link to post
Share on other sites
1 hour ago, MichaelB89 said:

Same here only i am on att u verse. it detects my ip as 250.120.85.81 which is similar to the 255.255 thing. i have not changed anything on my end either. can anyone tell me if this is a glitch? OS windows 10 pro, google chrome x64. thanks in advance!


250.x.x.x isn't a multicast nor private address space AFAIK....

Share this post


Link to post
Share on other sites

After talking to a few people....

1: It's most likely a testmy.net issue when reading the data in the packets.
2: If Hughesnet was showing a multicast address we wouldn't be able to perform the test as multicast traffic is dropped and kept local on a network typically.
3: Hughesnet does inject other stuff into our data packets, it's possible a change they made may be impacting people differently, such as how I can get it to show Hughes, yet Gabe can't...
4: All proxies typically inject extra data into a packet, that's normal behavior.
5: All other websites that check and report our IP addresses report back with the Proxy IP, OR if WAS is disabled, our "public" facing address.
6: This started happening between the 16th and nowish - has there been any changes at testmy.net to cause this?

Share this post


Link to post
Share on other sites

Regarding the IP thing: @CA3LE if I recall correctly, the SQUID proxy they mention utilizes the `X-Forwarded-For` header, are you perhaps checking that as well?

 

I know I had a similar issue with an Enterprise software application that was logging IP addresses, so I began logging the TCP/IP address and the X-Forwarded-For, as I was getting bizarre results similarly to what you are getting here.

 

I know, for a fact, that the 224.0.0.0/4 address space is Class-D (multicast) so no user should actually have that address, and 240.0.0.0/4 should be Class-E, and that's usually experimental / R&D.

 

Arin is being slow so while I'm looking into these additional details:

 

@C0RR0SIVE: The 250.x.x.x address is part of the experimental space, AFAIK (unless any new RFC's are out) it's used by R&D and for experimental use only.

 

So Arin finally loaded, and I'll give you guys the public URL: https://whois.arin.net/rest/net/NET-240-0-0-0-0/

Quote
Name:  SPECIAL-IPV4-FUTURE-USE-IANA-RESERVED

Comments: Addresses starting with 240 or a higher number have not been allocated and should not be used, apart from 255.255.255.255, which is used for "limited broadcast" on a local network.

This block was reserved by the IETF, the organization that develops Internet protocols, in the Standard document and in RFC 1112. The documents can be found at:
http://datatracker.ietf.org/doc/rfc1112

 

As I thought, this is still in the "special use" range, which should be mostly non-routed (though I don't think there are any bars against routing these addresses, it's just not common).

 

Thanks,
EBrown

Share this post


Link to post
Share on other sites
3 hours ago, C0RR0SIVE said:

This issue seems to still be persisting...  Any updates on this?  Was there any changes to how the website detects an ISP around the time this started happening?

 

Yep.  Still the same for me, no matter if my Web Acceleration is on or off.  Tried clearing the cache, flushing the DNS, and even tried with all four of the browsers I have.  No difference.  Nothing else to do, other than wait.  

 

It doesn't affect my actual test, of course, but it was nice to be able to compare my results to other Hughesnet users'.   

Share this post


Link to post
Share on other sites
13 hours ago, Gabe1972 said:

 

Yep.  Still the same for me, no matter if my Web Acceleration is on or off.  Tried clearing the cache, flushing the DNS, and even tried with all four of the browsers I have.  No difference.  Nothing else to do, other than wait.  

 

It doesn't affect my actual test, of course, but it was nice to be able to compare my results to other Hughesnet users'.   

 

FWIW, I have the same issue. 

Share this post


Link to post
Share on other sites
5 hours ago, oneup008 said:

Testmy.net is not detecting IPv6 address correctly. Disabling IPv6 fixes this issue. 

 

If your using the MaxMind DB there are different databases for IPv4 and IPv6 depending on how you have them stored on your end. 

Disabling IPv6 didn't make a difference, nor did disabling the Web Acceleration, but disabling IPv6 AND disabling Web Acceleration together did.  I'm going to change everything back to normal, but at least now I know what I can do to get it to show the provider if, for some reason, I need to.  I hope testmy fixes this issue.  Thanks for the help.  

Share this post


Link to post
Share on other sites
14 hours ago, Gabe1972 said:

Disabling IPv6 didn't make a difference, nor did disabling the Web Acceleration, but disabling IPv6 AND disabling Web Acceleration together did.  I'm going to change everything back to normal, but at least now I know what I can do to get it to show the provider if, for some reason, I need to.  I hope testmy fixes this issue.  Thanks for the help.  

 

Thats because they both use IPv6. Ofcourse you have to disable both because both are using IPv6. Web Acceleartion is doing the work somewhere else first and its using IPv6 on that end. So if you disable IPv6 on your computer but have Web Acceleration on its using IPv6 still to do the web acceleration. 

Share this post


Link to post
Share on other sites

I can confirm, disabling both does work, so it seems it's picking the wrong IPv6 address?

However, what @CA3LE showed earlier (in regards to the IPv4 address...) also makes things seem wrong as far as how testmy is detecting addresses...  So it seems both IPv4, and IPv6 isn't being detected properly in various scenarios with Hughesnet.

When I do a check at other websites, WAS ON, I see a Hughesnet IP... with WAS OFF,  I see yet another Hughesnet IP, not a 255 private/multicast address.

Testmy.net thinks I am at 241.67.19.41 right now (WAS ON), but, every other website says I am at 97.73.80.120...

The moment I turn WAS OFF (oh, and IPv6 is disabled too), testmy.net reports back with 97.73.80.120

So yeah, it seems to be a combo of things all at one time (was the IPv6 method working prior?).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
Speed Test Version 15.9
© 2017 TestMy Net LLC - TestMy.net - Terms & Privacy
© 2017 TestMy Net LLC - TestMy.net - Forum - Terms & Privacy