Sign in to follow this  
Followers 0
PastorP

Is Cavtel Causing My Ftp Issues?

19 posts in this topic

Hi everyone. I am using Cavtel's DSL. I am on Windows Server 2008 r2 Box with two AMD quad four opetrons. 20 gigs of memory. I am using dream weaver to upload to an online FTP web hosting site. When we had windows server 2008 standard our upload was working great. No problem. Hard drive locked up lost all date and upgraded to server 2008 r2. Now when we try to up load to the ftp it times out. The files we are uploading is about 50 mb and they time out or skip the file. If I up load a smaller file it is no problem. These are video files that we upload two a week. It is about 4 or 5, 50 mb files.

I talked with the router people and the web hosting they all point to Cavtel. Cave tel points to the web hosting. Does anyone have any ideas what may be the problem so that we can get back to a normal upload life?

Share this post


Link to post
Share on other sites

Don't you like how everyone points fingers at the other guy... always :rolleyes:

First of all, WOW on your system specs very nice. :shocked:

What ftp client are yo using. Have you thought that maybe the problem lies there?

I personally use Filezilla for all of my ftp client needs and have had no problems.

Also, do you have problems uploading with any other protocol besides ftp?

Share this post


Link to post
Share on other sites

Don't you like how everyone points fingers at the other guy... always :rolleyes:

First of all, WOW on your system specs very nice. :shocked:

What ftp client are yo using. Have you thought that maybe the problem lies there?

I personally use Filezilla for all of my ftp client needs and have had no problems.

Also, do you have problems uploading with any other protocol besides ftp?

First off Thanks this is our Domain server as well as our Media server thus all of the Mem. We built this from the ground up for under 1500.00. Oh forgot over 7 TB of HD space.

We were using dream weaver, but since the problem occurred we have tried filezilla which get the files up but it still times out and takes a long time.

Share this post


Link to post
Share on other sites

Set your time-out adjustments , you can find them in ~ Edit - Preferences and the Site > time out , I think 60 seconds is default .

Could be in IIS settings as well ~

Open your metabase.XML which is located in c:\Windows\System32\Inetsrv find the line "AspMaxRequestEntityAllowed" and change it to "1073741824". IE 1 GB

Share this post


Link to post
Share on other sites

I personally use Filezilla for all of my ftp client needs and have had no problems.

I can't believe you still use filezilla. You gotta upgrade bro, check out transmit. It's by far the best FTP program around.

Share this post


Link to post
Share on other sites

I can't believe you still use filezilla. You gotta upgrade bro, check out transmit. It's by far the best FTP program around.

I'll give that a try. I just love filezilla. It does exactly what I need it to do. One thing that bugs me however, at least on Mac, is if you click the filename wrong it thinks you want to rename it. Bugs the shit out of me. :-P

I'll give that a try when I get a chance. :)

Share this post


Link to post
Share on other sites

Set your time-out adjustments , you can find them in ~ Edit - Preferences and the Site > time out , I think 60 seconds is default .

Could be in IIS settings as well ~

Open your metabase.XML which is located in c:\Windows\System32\Inetsrv find the line "AspMaxRequestEntityAllowed" and change it to "1073741824". IE 1 GB

There is no line with "AspMaxRequestEntityAllowed".

Share this post


Link to post
Share on other sites

Ok , sorry your running IIS 7 with 08' , that should be ~ appcmd set config /section:asp /maxRequestEntityAllowed:int

Or you may get there via taskbar, click Start, Administrative Tools, and then click Internet Information Services (IIS) Manager. > Connections > home > ASP > Limits Properties , you should see it there

This could be so many things is why i think there pointing fingers , hahah , Just checking the obvious first.

I don't have to much access to 08' , still using 03 , cause it works for the local junk I have. And thats all getting moved to a linux box.

Also you can check your ftp compatibility to "passive mode " .

If nothing works , disconnect if possible your local router and get a straight through connection , just to rule out the local router isnt the issue.

Share this post


Link to post
Share on other sites

Replace Router with new router. removed router and went straight from modem. I remember that we had a problem simliar to this before when we first got Cavtel and we used DR tcp to straighten it out, but from my understanding that DR tcp will not work on windows server 2008. so any other ideas?

Share this post


Link to post
Share on other sites

also when this server was down we had a windows 7 box 64 bit with gig of ram on here and the same thing. Also there is a windows 2008 32 bit server on this network. all are doing the same thing.

Share this post


Link to post
Share on other sites

The common denominator if you will , here is obviously the program used to upload and or connect. ''If you have another way of uploading to the server a large file , try this , and rule out anything other then dreamweaver , yea ?

Then move from there.

Share this post


Link to post
Share on other sites

We did we used filezilla. Filezilla still shows a timing out. So what else could it be? Could it be MTU? If it is how in the owrld do you fix MTU in network or modem or router?

Share this post


Link to post
Share on other sites

Well I'm no dreamweaver expert , but if other servers did the same thing with dreamweaver , and another ftp client doesn't , I can only assume it's related to dreamweaver. And it's well known for various ftp related issues.

Did you go in and change the timeout settings in DW ? It must be related.

Share this post


Link to post
Share on other sites

Was trying to find where to edit registry value for RWIN in 2008 Server, and I stumbled on this article:

http://www.speedguide.net/read_articles.php?id=2574

Compound TCP - Improve throughput

Add-On Congestion Control Provider

The traditional slow-start and congestion avoidance algorithms in TCP help avoid network congestion by gradually increasing the TCP window at the beginning of transfers until the TCP Receive Window boundary is reached, or packet loss occurs. For broadband internet connections that combine high TCP Window with higher latency (high BDP), these algorithms do not increase the TCP windows fast enough to fully utilize the bandwidth of the connection.

Compound TCP (CTCP) is a newer method, available in Vista and Server 2008 (there is also a hotfix available for XP/2003). CTCP increases the TCP send window more aggressively for broadband connections (with large RWIN and BDP). CTCP attempts to maximize throughput by monitoring delay variations and packet loss. It also ensures that its behavior does not impact other TCP connections negatively.

By default, Vista and Windows 7 have CTCP turned off, it is only on by default under Server 2008. Turning this option on can significantly increase throughput.

To enable CTCP, in elevated command prompt type:

netsh int tcp set global congestionprovider=ctcp

To disable CTCP:

netsh int tcp set global congestionprovider=none

Possible options are: ctcp, none, default (restores the system default value).

Recommended setting: ctcp

It is better to use this newer generation CTCP congestion control algorithm for most broadband connections, we highly recommend it being turned on.

Worth a shot........

Share this post


Link to post
Share on other sites

well i dont see how it could be , but then again , i dont know why increasing the timeout doesnt fix it either. If a smaller file goes , then the server is still talking to the client , if the server times out during a larger file , this can mean that the client is not 'tickling the server to keep it alive. It could also mean that the max post size and file in php.ini is set to low , have you looked at this ?

-max upload filesize -max post

Share this post


Link to post
Share on other sites

well i dont see how it could be , but then again , i dont know why increasing the timeout doesnt fix it either. If a smaller file goes , then the server is still talking to the client , if the server times out during a larger file , this can mean that the client is not 'tickling the server to keep it alive. It could also mean that the max post size and file in php.ini is set to low , have you looked at this ?

-max upload filesize -max post

No not even sure where I would for that. Would this be on our machine or would this be something in the web hosts, or on the web hosting?

Share this post


Link to post
Share on other sites

Sorry took me so long to get back.

php.ini should be in the root folder of the server ie~ c:php/ i think this depends on if your running 64 or 32 bit server, also might be settings in the fastcgi or php-cgi.exe ,

I'm not real familiar with a windows server so I hope someone else that does comes in here for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0